WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form DB
[Plugin: Contact Form 7 to Database Extension] Problem with DB export after update (13 posts)

  1. avmcsmu
    Member
    Posted 3 years ago #

    Hello Michael.

    Thank you for great work and fast bug fixes. I have a new problem for you, sorry for that :( After update to 1.6 version I can not export db in admin area. No one method (excel,google,csv,html etc) do not work. I have tested my blog on local (denwer) and web host, i have updated plugin to 1.6.2 - the same.

  2. Michael Simpson
    Member
    Plugin Author

    Posted 3 years ago #

    I'm not sure what this is. As a first step, take a look at the HTML source of the page.
    1. See if it ends in </html>.
    2. See if there is any malformed html around the "CF7DBPlugin_form" form.

  3. avmcsmu
    Member
    Posted 3 years ago #

    thank you for fast reply
    I have checked things you recommended and :`(
    1 yes
    2 no, it seems to be ok
    I had turned off my firewall and antivirus and tried again with no results. My version (i'm not programmer) was "it is caused by large form" (cons: it worked). Well. I made new form (3 fields only). The same :( ! Forms get submisiion, i see them in admin area, may place on pages and in posts but cannot export.
    I use IE8 and Opera. Look what Opera javascript error console writes when i press export button:

    JavaScript - http://prlz.com.ua/wp-admin/admin.php?page=CF7DBPluginSubmissions
    Event thread: click
    Uncaught exception: TypeError: 'jQuery("#GoogleCredentialsDialog").dialog' is not a function
    Error thrown at line 3, column 28 in exportData(encSelect) in http://prlz.com.ua/wp-admin/admin.php?page=CF7DBPluginSubmissions:
        jQuery("#GoogleCredentialsDialog").dialog({ autoOpen: false, title: 'Google Login for Upload' });
    called from line 1, column 0 in <anonymous function>(event):
        exportData(this.form.elements['enc'])

    may be it will be helpful.

  4. Michael Simpson
    Member
    Plugin Author

    Posted 3 years ago #

    That is helpful. In your page source, does this appear anywhere?

    jquery-ui-dialog

    And this:
    http://ajax.googleapis.com/ajax/libs/jqueryui/1.8.6/themes/base/jquery-ui.css

    If so, post what you have.

  5. avmcsmu
    Member
    Posted 3 years ago #

    yes. I found jquery-ui-dialog in the footer:
    <`script type='text/javascript' src='http://prlz.com.ua/wp-admin/load-scripts.php?c=0&load=hoverIntent,common,jquery-color,jquery-ui-resizable,jquery-ui-draggable,jquery-ui-dialog&ver=eda73c4bb496c9ab78d3f21018084657'></script>

    <script type="text/javascript">if(typeof wpOnload=='function')wpOnload();</script>
    </body>
    </html>`

    and in the <head></head> part of source among many other scripts and link rels tags:

    <link rel='stylesheet' id='jquery-ui.css-css' href='http://ajax.googleapis.com/ajax/libs/jqueryui/1.8.6/themes/base/jquery-ui.css?ver=3.0.4' type='text/css' media='all' />

  6. avmcsmu
    Member
    Posted 3 years ago #

    more correct message:

    <script type='text/javascript' src='http://prlz.com.ua/wp-admin/load-scripts.php?c=0&load=hoverIntent,common,jquery-color,jquery-ui-resizable,jquery-ui-draggable,jquery-ui-dialog&ver=eda73c4bb496c9ab78d3f21018084657'></script>
    <script type="text/javascript">if(typeof wpOnload=='function')wpOnload();</script>
    </body>

    and in the <head></head> part of source among many other scripts and link rels tags:

    <link rel='stylesheet' id='jquery-ui.css-css' href='http://ajax.googleapis.com/ajax/libs/jqueryui/1.8.6/themes/base/jquery-ui.css?ver=3.0.4' type='text/css' media='all' />

  7. Michael Simpson
    Member
    Plugin Author

    Posted 3 years ago #

    For now, in Admin Contact -> Database Options and set Use Javascript-enabled tables in Admin Database page to false and see if export works.

  8. Michael Simpson
    Member
    Plugin Author

    Posted 3 years ago #

    Also: before you turn that off, change your theme back to the WP Default or "Twenty Ten" temporarily and see if that works. That will tell us if there is a conflict with the Theme.

  9. avmcsmu
    Member
    Posted 3 years ago #

    done. export is still doesnt work. As you know WP team has launched 3.0.5 version of WP. Should I try to upgrade it?

  10. avmcsmu
    Member
    Posted 3 years ago #

    i have deleted all plugins even Hello Dolly. No result. The plugins i have are Akismet, Contact Form 7,Contact Form 7 - Dynamic Text Extension,Contact Form Backup/Restore,Contact Form to DB Extension. I deactivated all except CF7 and CF7DB - no results. I will try En (no UA or Ru that i use now) WP version and will write about results.

  11. Michael Simpson
    Member
    Plugin Author

    Posted 3 years ago #

    I don't expect WP 3.0.5 to affect it.

    The problem looks like jQuery or jQuery-Dialog is not being loaded/recognized. This is actually only needed for the Google Spreadsheet export option. So I'm going to push an update soon (1.6.3) that should minimally make all the other exports work for you, and Google Spreadsheet options should throw up an error (try that and post the error).

  12. avmcsmu
    Member
    Posted 3 years ago #

    ok. So it's better to wait. Thank you for good support.

  13. Michael Simpson
    Member
    Plugin Author

    Posted 3 years ago #

    What is the status now?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic