WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form DB
[resolved] [Plugin: Contact Form 7 to Database Extension] plugin does not work, does not save data (2 posts)

  1. allm
    Member
    Posted 2 years ago #

    I have used this excellent plugin before on a few sites, to save data from fscf. Never had a problem, until now.

    A few weeks ago I tried the plugin again. It is for a website that runs on another hosting platform than the sites for which I used this plugin successfully before. It didn't work. I left it at that, because there was a lot of other things to do.

    Today I noticed there is another version of the plugin so I tried again. I started by deleting the previous version and installing the new version. This resulted in the message: The plugin generated 753 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.

    The plugin did not work. After that I deleted the plugin again, but to be sure I checked the "Drop this plugin's Database table on uninstall" check box first. Re-installing did not result in the error message above, but the plugin still does not work.

    If I submit a form it does not get into the database.

    It is rather late now, so I will do some more checking tomorrow. I will start by using PhpMyAdmin to see what tables (if any) the plugin created in the db.

    I am using mySQL version 5.1.41-community and PHP 5.2.4

    I would be grateful for any ideas that can help me find a solution.

    http://wordpress.org/extend/plugins/contact-form-7-to-database-extension/

  2. allm
    Member
    Posted 2 years ago #

    Oooops! Even after using this plugin successfully on some other websites, on various hosting platforms, I missed something. The solution to the problem above is soooooooooo simple. I forgot to set the "Data Export" checkbox in the FSCF form definition. That's what you get when you restore a backup of the form definitions from another site and do not look at it in detail...

    I lost some time on searching for a solution, and I hope no one else wasted time on this...

    I'll go hide somewhere for an hour (but happy it works now!)

    I'll set this to "resolved"

    :-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags