WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Contact Form 7] submission successful but no email (27 posts)

  1. fl3x7
    Member
    Posted 5 years ago #

    hello,

    Ive had a quick look at various contact forms and this one seems to be by far the coolest and most advanced.

    i have an issue though :(. Everything submits successfully and i get the green box but i do not recieve the email. Its not being filtered as spam or being rejected by certain clients as i tried with gmail, hotmail etc

    It also does not actually detect the spam either. i tried the spam example you suggest on your website without any luck.

    Disabled all plugins, still no luck. Ive read any threads about the issue were fixes have been suggested tried but none have worked so far :(

    Not sure what to try now :(

    Hope someone can help and thank you for reading

  2. truetone
    Member
    Posted 5 years ago #

    I have a similar issue. If I set the email address of the form to my Gmail address, I receive messages immediately. When I change the email address to one with the same domain as the website, the messages disappear.

    I'm using Google to host the domain's email, so I have a feeling it has something to do with the mail being sent locally, when really I should be using the Gmail SMTP server. Thoughts anyone?

  3. bobpotter
    Member
    Posted 5 years ago #

    I third this. I use Google Apps, which is the admin email for the site. Upon submission, it confirms it was sent, but the form never shows up in the email.

    I added a gmail address and it sent the form through fine.

  4. truetone
    Member
    Posted 5 years ago #

    I took a look into the source code and Contact Form 7 just wraps the email up and then sends it to WordPress' wp_mail() function.

    if ( $attachments ) {
    		$for_this_mail = array();
    		foreach ( $attachments as $name => $path ) {
    			if ( false === strpos( $mail_template['attachments'], "[${name}]" ) )
    				continue;
    			$for_this_mail[] = $path;
    		}
    		return @wp_mail( $mail_recipient, $mail_subject, $mail_body, $mail_headers, $for_this_mail );
    	} else {
    		return @wp_mail( $mail_recipient, $mail_subject, $mail_body, $mail_headers );
    	}

    Perhaps the issue lies there. Unfortunately that function is poorly documented at the moment.

  5. tysoncrosbie
    Member
    Posted 5 years ago #

    I am also having this same problem on a couple of sites using cpanel and the titan theme.

    It will send one email if enabling the mail (2) function. But it is not consistent, one site it only sends the first and the other site will only send the second..

    Really would like a solution for this problem, can't find anything yet.

    Thanks.

  6. dotcomjohn
    Member
    Posted 5 years ago #

    I'm having exactly the same problem, across all my WP sites with Contact Form 7 - form submits fine, but nothing received. I also had one site set up to send an auto-responder message to users, but they've not received any auto-responder messages, as the form submission isn't getting to the mail server in order to perform the auto-respond function.

    Interestingly enough, if I change MY recipient address to a hotmail account, the submission shows up in the junk folder.

  7. truetone
    Member
    Posted 5 years ago #

    As I mentioned in my previous message, I'm using Google's free email service in my case. I had a feeling the server was only sending the mail locally, since mail to addresses outside the domain worked, but mail to addresses in the domain were not received via Google's interface. I logged into the server control panel and deactivated mail on the account and the messages then started getting through. I hope this helps someone. I also tracked down where the wp_mail() resides. It's in wp-includes/pluggable.php. It basically just uses php-mailer, a tried and true PHP mail script.

    I hope to update the documentation for that function, since the wiki page is just a stub. Does anyone know if WordPress is going to publish an API any time soon? It certainly would be useful.

  8. Mark
    Member
    Posted 5 years ago #

    This may seem obvious, but did you check your other email accounts Spam box? I am using this plugin and it's sending emails to other accounts with out problems. Although I am having a strange "blank image" for the Captcha that I'm looking into in another thread. It doesn't make any sense that you'd be getting emails to GMail but not to other accounts without some issue with that other email account like it being blacklisted or thinks those messages are spam or something.

  9. mattyk
    Member
    Posted 5 years ago #

    I'm having what I think is the same problem.

    If I send an email to my hotmail address I get the email.

    Any other address I get nothing.

    The hotmail address is the one I set up for my admin. Could this have something to do with it?

  10. mattyk
    Member
    Posted 5 years ago #

    I'm still having this problem even after uninstalling and deleting it.

    I can only send the form to my hotmail account which is the one I used when setting up wordpress.

    I don't have this problem on other sites that are set up with different hosting companies.

    Could this have something to do with the way my server is set up?

    Maybe someone could recommend an alternative script or plugin?

    thanks

  11. mattyk
    Member
    Posted 5 years ago #

    OK this gets weirder.

    If I set it to go to hotmail or gmail it gets through.

    I've tried a couple of other email addresses but get nothing. I've checked the junk mail folder and they don't go to there either.

  12. mattyk
    Member
    Posted 5 years ago #

    Just to follow up.

    In my case this had nothing to do with contact form 7.

    The emails that WordPress sends out were only getting through to some email clients. Most of the time they didn't even end up in spam folder.

    I think it might be some kind of server setting where some mail clients were unable to receive the emails.

    M

  13. acknowledged74
    Member
    Posted 4 years ago #

    The problem I have it that the email are sent and received but some only of the info arrives, i.e. just the title and message not the senders contact details ?

  14. Brian Jones
    Member
    Posted 4 years ago #

    I am having the same problem as truetone mentioned.

    I am currently using Google Apps to host the email for my blog and any email sent by contact form 7 just isnt getting to the google apps e-mail account, as truetone stated it as if its being sent locally.

    Truetone mentioned he had solved this problem: "I logged into the server control panel and deactivated mail on the account and the messages then started getting through. "

    Truetone can you explain this or can someone else explain how to do this?

    Thankyou

  15. Brian Jones
    Member
    Posted 4 years ago #

    Good News!

    I managed to fix the problem, for me anyway.

    Open the file wp-includes/class-phpmailer.php

    In the file you should find:

    // PROPERTIES FOR SMTP

    In my file its on line 166.

    Below that you can edit the SMTP information for wordpress, if you are using googleapps you can use the following information for that:

    host: ssl://smtp.gmail.com
    port: 465
    smtpsecure: tls
    smtpauth: true
    username: your google apps username
    password: your google apps password

    Just leave the other smtp settings as they are.

    Save that file and upload, now any emails being sent via a contact form from your blog should send just fine.

  16. carloan
    Member
    Posted 4 years ago #

    There is a plugin for the SMTP http://www.callum-macdonald.com/code/wp-mail-smtp/ with this and make sure you have reverse DNS setup and it should work.
    I just did the following and just waiting for things to propogate. I hope this helps.

  17. szelee
    Member
    Posted 4 years ago #

    My solution without messing with any other plugins or wordpress's native files.

    Quoting TrueTone's post

    I logged into the server control panel and deactivated mail on the account and the messages then started getting through. I hope this helps someone.

    and AlexMearns'

    Truetone mentioned he had solved this problem: "I logged into the server control panel and deactivated mail on the account and the messages then started getting through. "

    Truetone can you explain this or can someone else explain how to do this?

    For me, under the DirectAdmin settings (thats what my webhost provides as control panel), go to Email Management -> MX Records, and uncheck the checkbox that says "Use this server to handle my mails".

    See screenshot here.

    For cPanel, its probably under Mail->MX Entry->Email Routing

  18. Arnii
    Member
    Posted 4 years ago #

    All right, I have the same problem as everyone here. But what is totally weird here, is that everything works as it should in Safari and Firefox. But in IE7 and IE8 Contact Form tells me that the mail is sent. But I never receives the mail.

    In the other browsers I do...

    As I see it, it cannot be a server problem, if it works in some browsers and not in others.

    Any suggestions on that?

  19. miketheteacher
    Member
    Posted 4 years ago #

    Same problem. Just arose after latest upgrade.

  20. Arnii
    Member
    Posted 4 years ago #

    UPDATE. The mail is received. But I really don't get it. In Safari / FF the mail is received almost immediately. When I use the form through IE, the mail is received a couple of hours after the submission.

    Just weird. But hey – it works...! In some way...

  21. adrienj
    Member
    Posted 4 years ago #

    Resolved by using HGK SMTP extension to reconfigure WordPress email to use SMTP instead of the default wp mail() function.

  22. artcola
    Member
    Posted 4 years ago #

    Did the fix that szelee suggested

    For cPanel, its probably under Mail->MX Entry->Email Routing

    And now I get emails!

  23. Andrew Davis
    Member
    Posted 4 years ago #

    The cPanel fix worked for me too.

    1. From cPanel, under Mail, click MX Entry.
    (This takes you to the MX Entry Maintenance screen.)

    2. Under Email Routing, select the Remote Mail Exchanger option, and then click Change to confirm.
    (My original setting had been Automatically Detect Configuration.)

  24. thouston
    Member
    Posted 4 years ago #

    Thanks - the mod through cPanel (as described above by pindy) worked for me too - so easy when you know how!

  25. TexasTaxPayer
    Member
    Posted 4 years ago #

    I think I may have the answer. to this. i had a similar same problem with Another WordPress Classifieds Plugin and now also Plugin: Contact Form 7.

    The Contact Form 7 plugin will not let me use the same email address as my default WPMU email. whereas AWPCP required I use the default email address.

    It works now though.

  26. irfun4ever
    Member
    Posted 4 years ago #

    i tried this way , its working yesterday but today doesnt working again.

  27. spencerjw
    Member
    Posted 4 years ago #

    Mine is still not working. I tried changing addresses to send to but nothing. It has worked flawlessly for the last few months since I installed it and just about a week ago it totally stopped working.

    I tried sending to a gmail account as well as an account at the domain of my website (which Google hosts the email for) and still nothing. No errors either.

Topic Closed

This topic has been closed to new replies.

About this Topic