WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
Stopped sending all of a sudden (7 posts)

  1. Darthmoon
    Member
    Posted 2 years ago #

    The Contact Form 7 plugin is awesome, has always worked perfectly for more than a year and I love it!

    But all of a sudden I noticed it stopped working and doesn´t send the e-mails anymore.

    I have deactivated the plugin and reactivated it and noticed it only sends 1 (one) e-mail after this procedure (deactivation and reactivation of the plugin).

    This is so weird!

    I´m using WordPress 3.0.5 and Contact Form 7 2.4.3

    I tried to upgrade to version 2.4.5 but still the same problem.

    Any help is welcome!

    http://wordpress.org/extend/plugins/contact-form-7/

  2. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 2 years ago #

    Do you receive other mail from WordPress such as comment notification? If not, it is highly possible that the mail service on your host has some troubles. Contact the host's support.

  3. Darthmoon
    Member
    Posted 2 years ago #

    In fact, I don´t use the comment feature in my website, so I can´t tell...

    What is weird is that it works only once after deactivating and reactivating it, but as you said, I´ll check the mail service on my host to see if it´s running right.

    Thank you Mr. Takayuki! I need to get it fixed because your plugin is very good and has always worked greatly! I like it a lot ;D

  4. cdhealy
    Member
    Posted 2 years ago #

    I am receiving mails from wordpress like user registrations etc, but the contact form gives me the confirmation the form has been sent but never receive the email. site is http://www.wecleanit.ie

  5. truck808
    Member
    Posted 2 years ago #

    Hi Did you ever resolve this? I am having a similar issue.

  6. NearlyNubile
    Member
    Posted 2 years ago #

    Hi. Hope this helps someone. I had a similar issue some days ago. Email stopped sending.

    I realized that my hosting company had made email rules more stringent in their WHM(Cpanel). So the "nobody" user couldn't send any email.

    To work around this, I did something better. I downloaded the fantastic "Configure SMTP" plugin -- http://wordpress.org/extend/plugins/configure-smtp/ -- and setup email sending via authenticated SMTP user from my domain.

    Now the contact form (and all other) email is sent via SMTP. Which is more secure and works.

  7. Darthmoon
    Member
    Posted 2 years ago #

    NearlyNubile, it really might be some kind of email issue at the hosting, I remember my host sent an email noticing some changes on their email service by the time I had this problem with the plugin.

    As I am very newbie at programming and stuff, I haven´t tried to fix it yet, I just toke the plugin out of my website until I have time to do it.

    When I have time I will try your fix, thank a lot for sharing the tip!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic