WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
[resolved] Second form Submit button issue with Acceptance (3 posts)

  1. da_n
    Member
    Posted 3 years ago #

    I am having an issue with creating a contact form with Acceptance checkbox. Essentially the submit button creates an extra attribute in it, which means the Submit button does not work in FireFox, Chrome and Safari. Without the checkbox, the form submit button code looks like this:

    <p><input type="submit" class="wpcf7-submit" value="Send"><img src="http://[website-url-removed]/wp-content/plugins/contact-form-7/images/ajax-loader.gif" alt="Sending ..." style="visibility: hidden;" class="ajax-loader"></p>

    With acceptance the input field changes to look like this

    <p><input type="submit" class="wpcf7-submit" value="Send" disabled=""><img src="[website-url-removed]/wp-content/plugins/contact-form-7/images/ajax-loader.gif" alt="Sending ..." style="visibility: hidden;" class="ajax-loader"></p>

    It appears disabled="" is being introduced and this is causing issues (even though it is not disabled="disabled"), if I edit the HTML with FireBug and remove the attribute then the form works as expected. I have tried disabling JavaScript and the output is the same, so it is not being generated via JS. I am guessing this is a bug however I need this form desperately as I am showing a client this website tomorrow! Any help would be hugely appreciated.

    http://wordpress.org/extend/plugins/contact-form-7/

  2. da_n
    Member
    Posted 3 years ago #

    Hang on, I am being an idiot it appears, the submit button will not work unless the check box is first ticked! Would be good to have some form of feedback for this to the user, maybe something to consider in a future release?

  3. Burke Ingraffia
    Member
    Posted 3 years ago #

    I am having the same problem.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic