WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Contact Form 7] Not working (27 posts)

  1. elementel
    Member
    Posted 4 years ago #

    Ok this is probably as vague as it comes but a client's site has contact form 7 and it's not working. He had his email in the settings correct and I tried submitting a test to him. The form worked properly, said message was sent. Nothing received. I changed the email address to my own in the settings to see if his email system is the culprit. It's been ten minutes now and I have not received any email.

    I'm running the latest version with the latest version of wordpress.

    Thanks!

  2. dsmithson
    Member
    Posted 4 years ago #

    Im having this exact same issue.

    Is it not compatible with the new version of WP?

  3. Johnny Bravo
    Member
    Posted 4 years ago #

    same here! wheres these emails going?
    hh

  4. gdjones83
    Member
    Posted 4 years ago #

    I'm having this problem on one of my sites too, everything seems fine, form confirms that it's been successfully sent but nothing reaches my inbox.

  5. gti
    Member
    Posted 4 years ago #

    I have also been having this problem - anyone found a solution yet. The contact form sends emails to an email @hotmail.com but not to an email @mydomain.co.uk

  6. ocularharmony
    Member
    Posted 4 years ago #

    I was having the same problem but resolved it. Make sure that the "from" field displays the correct information. I switched the [your-name] field to [first-name] in the contact form, but not in the "from" area, which needs to match.

  7. rlebowitz
    Member
    Posted 4 years ago #

    With all due respect, ocularharmony, I am not sure what you mean. I have not touched the "from" area. And I am not getting *any* emails!

    Thanks in advance for any help!!

  8. rlebowitz
    Member
    Posted 4 years ago #

    Sorry for this double post--not sure how to delete something once I posted it!

  9. nachocomar
    Member
    Posted 4 years ago #

    Same here! As gti said... Works fine when sends to "@gmail.com" but doesn't work if I send it to an address that end with ".com.ar".

  10. miketheteacher
    Member
    Posted 4 years ago #

    Same problem. Will not sent to any email address since upgrade.

  11. adrienj
    Member
    Posted 4 years ago #

    Resolved by using HGK SMTP extension to reconfigure WordPress email to use SMTP instead of the default wp mail() function.

  12. EC (Lisa) Stewart
    Member
    Posted 4 years ago #

    I'm getting the same thing and I *haven't* upgraded the Contact7 form. I just tested the basic form that it came with and then received the dreaded error msg.

    I wonder if it's because of the WP upgrade?

  13. X-Evolutionist
    Member
    Posted 4 years ago #

    I just installed this. I tried to send myself an email, and I had my hubby send me an email from work. I did not get either one. I did a google search and found this post.

    Contact Form 7 is listed under "Most Popular", but it's not working for me.

    What is the best and most reliable contact form? I have Version 2.9.2.

    Thank you,

    X

  14. X-Evolutionist
    Member
    Posted 4 years ago #

    I got the first email I sent finally. It took over an hour to get to me. It works though, so that's good.

    X

  15. Paul Hisson
    Member
    Posted 4 years ago #

    Thanks to adrienj and HGK SMTP extension, this problem is now solved for me.

    My WordPress version is 2.9.2 and the latest version of Contact Form 7 did not work (no error message, but no emails were sent). I downloaded, installed and configured HGK SMTP extension with correct SMTP parameters and everything works fine now.

    Thank you again, adrienj!

  16. X-Evolutionist
    Member
    Posted 4 years ago #

    Clarify please, what is this and where do I get it?

    HGK SMTP extension with correct SMTP parameters

    Thank you,

    X

  17. Ashfame
    Member
    Posted 4 years ago #

    If I enter a matching email address (as in General settings) in From field, then the form works but if I change both of them (still matching with each other), then the mails are not sent.

    Any ideas?

  18. Ashfame
    Member
    Posted 4 years ago #

    Or is it something that WordPress email (as in General settings) take some time to reflect? It shouldn't be but I am out of ideas.

  19. X-Evolutionist
    Member
    Posted 4 years ago #

    I would like to add to my post above. When I installed this, I sent a test email and had my hubby send a test email. They both eventually came to me, but the second one took days to reach me.

    I decided not to use it. I'd like a recommendation for the most reliable email plugin.

    X

  20. Ashfame
    Member
    Posted 4 years ago #

    I got in touch with my webhost, they fixed a thing and now it works flawlessly. This plugin is awesome. You need not consider anything else. Another powerful enough plugin is Cforms II

  21. boogieboa
    Member
    Posted 4 years ago #

    Plugin NOT working since the last update. Produces a blank screen when [contact-form 1 "Contact form 1"] added to the page. When removed, everything is fine, except there's no Contact Form. Tried reverting to an older version but that didn't solve the problem. Help!

  22. Priscila
    Member
    Posted 3 years ago #

    FIX

    The SMTP needs to be authenticated. Download and install the WP Mail SMTP plugin. Once the local server information is added in Settings >> Email, the emails should get sent out to any outside email addresses.

    Link to plugin: http://wordpress.org/extend/plugins/wp-mail-smtp/

  23. Priscila
    Member
    Posted 3 years ago #

    Plugin NOT working since the last update. Produces a blank screen when [contact-form 1 "Contact form 1"] added to the page. When removed, everything is fine, except there's no Contact Form. Tried reverting to an older version but that didn't solve the problem. Help!

    I'm probably a little late on this now.. but I believe you might just have to activate the plugin again in the PLUGINS section.

  24. gaysurfers
    Member
    Posted 3 years ago #

    Hi Priscilia
    I tried your FIX to install the WP Mail SMTP plugin and authenticate SMTP
    Still not receiving the emails.
    I left SMTP Host and Port empty, just filled in the login and password... I get the test email from the WP Mail SMTP plugin, but still cant receive the emails sent from contact form 7...
    Any other idea?

  25. Priscila
    Member
    Posted 3 years ago #

    Hello
    The smtp host and port shouldn't be left empty. Normally by default, most server uses 25 or 50 for port. Do you know what the smtp host is for your email account you are using? Let me know if you need help identifying it.
    Priscila

  26. gaysurfers
    Member
    Posted 3 years ago #

    Awsome thanks Priscila!
    It works now!!!

  27. Priscila
    Member
    Posted 3 years ago #

    Awsome thanks Priscila!
    It works now!!!

    You're welcome! Glad it works out for you :)

Topic Closed

This topic has been closed to new replies.

About this Topic