WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
not sending e-mail (19 posts)

  1. cronaged
    Member
    Posted 3 years ago #

    hi, First of all Thank you very much for your script. it is a very successful operation. However it is not sending an e-mail.
    For example:http://www.skalaajans.com/ajans/bize-ulasin.html
    What is the problem do you think? help me please..

  2. Tifa
    Member
    Posted 3 years ago #

    I have the same problem. When I press submit, I just see the "loading" icon, just loading endlessly... The submissions does not go through my inbox either.

    I also tested other forms and it seems all of them does not work. I am not sure what's the error.

    Any help would be appreciated. Thanks!

  3. Tifa
    Member
    Posted 3 years ago #

    Hi,

    anyway, I found out the error on my end. I used to have "wp-cache" plugin on my site and I removed it coz of some issues. And this plugins usually adds a line of code in your wpconfig.php. So I just remove the:
    define('WP_CACHE', true);

    And my forms are working again. I am not sure if this is the same for you cronaged, but you should try disable some plugins might be some conflict.

  4. cronaged
    Member
    Posted 3 years ago #

    Thank you for your help but there isn't this line in wp-config.php. I couldn't understand

  5. johncharlton
    Member
    Posted 3 years ago #

    @fw

    Thanks. That solved it for me.

    I removed define('WP_CACHE', true); from wpconfig.php and the form started to work again.

  6. rcajavilca
    Member
    Posted 3 years ago #

    Tag that generates "Contact Form 7 is
    <p>Tu nombre (obligatorio)
    [text* text-468 akismet:author]</p>
    <p>Tu email (obligatorio)
    [email* email-705 akismet:author_email] </p>
    ---
    I followed the instructions to place the codes, and the form works but get sent to my gmail email as spam, and corporate email does not reach out this form.
    I appreciate if you can help.

  7. Tifa
    Member
    Posted 3 years ago #

    @cronaged: Be sure that the wpconfig is the one you have downloaded from your domain. Anyway, if you can not find the code I mentioned in wpconfig.php. Then I think you should first try this:
    1. open your header.php, located in /wpcontent/themes/yourtheme/, and check if it has this line of code before </head>:
    <?php wp_head(); ?>

    2. Do the same with your footer.php check before end of </body> if it has:
    <?php wp_footer(); ?>

    Those codes are important to make your plugins work correctly.

    --
    @rcajavilca: be sure to make the "from" format as follows:
    [text-468] <[email-705]>

    I dont understand your language but I am guessing that's name & email.

  8. johncharlton
    Member
    Posted 3 years ago #

    The only problem I have to report using your fix above is that now I get a notice in my plugins drop-ins section that says for advanced-cache.php "Advanced caching plugin. Inactive: Requires define('WP_CACHE', true); in wp-config.php"

    Is this an issue?

  9. Tifa
    Member
    Posted 3 years ago #

    @johncharlton: Yes. If you are still using some caching plugin, you should not remove the define('WP_CACHE', true);. In my case, I am no longer using any caching plugins coz they dont' work (in my opinion).

  10. johncharlton
    Member
    Posted 3 years ago #

    Ya, I'm not a fan of caching plugins either, but this showed up not as a Plug-in but a Drop-in, which is listed in the Plug-ins section but as a separate category so in this case, I have 6 active Plug-ins plus one Drop-in.

    A note above the Drop-in states: "Drop-ins are advanced plugins in the /wp-content directory that replace WordPress functionality when present."

    I first noticed Drop-ins showing up in the Plugins section recently. I am running WordPress 3.0.4

  11. Tifa
    Member
    Posted 3 years ago #

    Ah, drop-ins. I thought they've been added by our hosting admin since the transfer. So now I think its a wordpress default. Anyway, if you really don't need it you can just download and save a copy on your PC (in case you change your mind later) and then delete the one in your domain's /wp-content. In my case, i have deleted my drop-ins coz I really don't need them.

  12. johncharlton
    Member
    Posted 3 years ago #

    Thanks. I did that and it is gone. I'll keep a local copy just in case I need it at some point.

    I also found wp-cache-config.php in there. I trashed that as well. I thought I had deleted it before along with the plugin, but there it was.

  13. rcajavilca
    Member
    Posted 3 years ago #

    Thanks for your reply, I found the lines of code and well ... I think the problem is mail.
    Moreover, I solved it with making a form in html and then I put it in the text editor of the contacts page and it worked.
    Thanks for the help they gave me.
    Until next time.

  14. mrclgoes
    Member
    Posted 3 years ago #

    @freelance webmasters

    I did it all sugested here and it is still not working. No one contact plugin has ever worked for me.

    I realize that contact form 7 works only if I use and email @mydomain.com

    wich is not likeble because only I have this kind of email...

    Please, would you have anything else on your sleeves?

    regards,

    Marcelo

  15. Tifa
    Member
    Posted 3 years ago #

    Hi mrcgloes,
    When you say:

    I realize that contact form 7 works only if I use and email @mydomain.com

    does it mean you can not use any free emails like google or yahoo mail?
    One solution I think is to disable all other plugins and check if its working. Then enable them one by one..This is to check if there are conflicting plugins. Another is to update your wordpress to the latest version. If still not working might be your theme, try choosing the wordpress default theme (twentyten)...Also did you get any errors at all?

  16. mrclgoes
    Member
    Posted 3 years ago #

    @freelance webmasters

    Yes. If you try to send me a message on my blog using my contact form if you write freelance@webmasters.com it will not be sent.

    I´ve got an message from my host that is not good.

    that´s the answer I´ve got from my host service. It was translated to english via babel fish

    Leading in account that its e-mails use servers of email (MX) of the Locaweb, some points exist that must be observed in the configuration of its form of contact:

    From field: OBLIGATORILY it must use a valid email and of its domain. This field is responsible for determining the shipper of the email sent through its form.

    Return-Path: We recommend that this field is filled with email the same used to carry through the sending of the message (in the case of errors during the sending, the error message will be sent for the email configured in this field). Although power to be filled with a different email of the used one in " From" , when filling this field with a different email some suppliers can consider the sent message as a Spam, carried through the blockade of the same one.

    Reply-To field: This field is responsible for defining an email for reply. That is, although an email to be sent through a post office box of its domain, when answering the message, the reply of the message will be sent for the email configured through this field. We suggest the use of this field disponibilizado for the fulfilling for the user of its site.

    By means of these information, we recommend that it can effect the due corrections in its application so that its form comes back to function. These alterations are necessary therefore all emails that if not to fit above in the informed standards, will be blocked by our new filter anti-Spam.

    anyway I will try you ideas and see if it work. but I belive it is caused by my host.

    regards,

    marcelo

  17. 4wehelp
    Member
    Posted 3 years ago #

    I am having the same problem. I deleted my cache plug in along with a few others, that didn't work. I changed the email addresses it was sent to, still didn't work. I have updated the wordpress page that the form is on, still nothing. Cleared my browser, quit and started over, still doesn't work.

    I am not so computer savvy so where do I find "wpconfig.php" so I can check it?

  18. Tifa
    Member
    Posted 3 years ago #

    @mrclgoes: Yes, it might be your host's problem. Ask them if they could remove the filter thing.

    @4wehelp: you should login to your host admin and view files from your site's directory. Or you can use an FTP program. wpconfig.php is located just on your worpress' root. Usually inside

    /public_html/wp-config.php

  19. mrclgoes
    Member
    Posted 3 years ago #

    @freelance webmasters

    thanks dude!

    see ya

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic