WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
[resolved] Not Receiving Emails (87 posts)

  1. foodiebuddha
    Member
    Posted 3 years ago #

    Hi there,
    I am not receiving emails through my contact form. Here is the link to the contact page

    and here is the code.

    <p>Your Name<br />
        [text your-name] </p>
    
    <p>Your Email (required)<br />
        [email* your-email] </p>
    
    <p>Subject<br />
        [text your-subject] </p>
    
    <p>Your Message<br />
        [textarea your-message] </p>
    
    <p>[captchac captcha-918 size:s]
    [captchar captcha-918]</p>
    
    <p>[submit \"Send\"]</p>

    Does anyone see a problem with this? I can't for the life of me figure out why it's doing this. I use google apps to host my email if that helps.

    http://wordpress.org/extend/plugins/contact-form-7/

  2. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 3 years ago #

    Please read the FAQs and documentations first.

  3. foodiebuddha
    Member
    Posted 3 years ago #

    Hi takayuki - thanks for the response, but i'm not exactly sure what you want me to read from that. i haven't changed anything in the form since i first installed it (before its current version) and something is now broken.

  4. cjvannette
    Member
    Posted 3 years ago #

    I'm having the same problem. I realized today that I haven't received a single contact form submission since upgrading WordPress. I just tested all of my forms, which had been working fine, and they are now not sending mail.

  5. joleephoto
    Member
    Posted 3 years ago #

    For what it's worth, I noticed this morning I'm not receiving e-mails anymore either. I haven't made changes, and the e-mail is sent to 2 different e-mail accounts through 2 different e-mail servers. Unfortunately, I guess I will have to switch to a plug-in that functions.

  6. joleephoto
    Member
    Posted 3 years ago #

    Nevermind, an update was created that showed up in WordPress after I posted this. I updated plug-ins this morning, but Contact7 wasn't on the list at that time. All messages to me that I hadn't received were sent as soon as I updated the plugin, very nice!

  7. chilaver
    Member
    Posted 3 years ago #

    ola amigos, tenho uma instalação de wordpress em meu site: http://www.visaoregional.com.br . para o formulario de contato, utilizo o plugin contact form 7. o problema é que não consigo receber emails de yahoo, gmail, hotmail e outros. gostaria de saber se isso tem a ver com a configuraçao do servidor. abraços e aguardo retorno

  8. frymi
    Member
    Posted 3 years ago #

    Plugin CF7 not work (broken). I am used WP v3.2/3.2.1 and CF7 v2.4.5/2.4.6. Why not function - not send mail?

    1) Send message
    2) Not receive to mailbox

  9. samanders
    Member
    Posted 3 years ago #

    Hi,

    Since updating to WordPress 3.2.0 The plugin fails to send emails, upon clicking on submit the sending icon is displayed but no confirmation message is shown and no email is received.

    WordPress has been updated to 3.2.1 and the Plugin is currently on 2.4.6

    All was working correctly until the recent updates, anyone have any suggestions?

  10. andregeuze
    Member
    Posted 3 years ago #

    I can confirm the same problem at my site. Using WordPress 3.2.1 and plugin version 2.4.6. Anyone found the reason and a fix yet?

  11. foodiebuddha
    Member
    Posted 3 years ago #

    is there any update on this? if not, does anyone have any experience with any of the other contact plugins? i'm considering just writing my own form but i'd rather not.

  12. orionis23
    Member
    Posted 3 years ago #

    Another with same problem. Stopped sending mail after WP update to 3.2... just finished styling the form up all nice too. Quite a drag...

  13. ryascolot
    Member
    Posted 3 years ago #

    Same here. Stopped sending emails after the update. The plugin creator has already responded to this thread with "Please read the FAQs and documentations first." But obviously if 50% of people are saying the latest release is broken...

  14. rhawkes
    Member
    Posted 3 years ago #

    As of right now, unless someone has learned something different, Contact 7 2.4.6 does not send e-mails with WP 3.2.1. Hopefully will see an update for Contact 7 very soon. Just got two long forms done, everything was fine and then I updated WP and now the mail does not come to me.
    Thanks
    Ron

  15. Wayne Anthony
    Member
    Posted 3 years ago #

    I had the same issues, mail not being received. I was using the latest versions of WP and Contact Form. As my website was playing up I deleted everything and reinstalled WP (latest version) and 2.4.5 version of the Contact form. Now it works. I am also slowly getting all the mails I sent to "myself" when I was checking the form!

    Now I don't know if it's because I wiped my website and did a total fresh installation of WP then used the prior version of the Contact Form, OR because I used the 2.4.5 version. I never thought to try the previous version BEFORE I wiped it clean. Maybe someone might want to try the 2.4.5 version and see if it works for them? I don't know if theres a copy around, if not get in touch and I will mail it to you.

    Hope this helps

    Anthony

  16. samanders
    Member
    Posted 3 years ago #

    I have just reverted the plugin back to 2.4.5 and same problem no email is sent the sending icon just scrolls and no email is sent

    From memomey the 3.2 update included changes to jquery?

    Looking at the page loading it looks like jquery is throwing an error in wp-includes/js/jquery/jquery.js?ver=1.6.1 - Line 18 Char 19570

    could this be the issue? i am not a coder so not sure what the issue could be, any one else have any suggestions?

  17. WannesMorris
    Member
    Posted 3 years ago #

    Works @ my sites in WordPress 3.2.1 so maybe a conflict with other plug-ins ???

  18. bernwa
    Member
    Posted 3 years ago #

    Hi ... I installed the form over an hour ago and sent an email but have not received it. I see other people are having the same problem. Here is my page if anyone can help:

    http://bvcwebdesign.com/?page_id=8

    Thanks so much!

    BC

  19. Bozz
    Member
    Posted 3 years ago #

    Also having a problem not receiving e-mails on 3.2.1

  20. bernwa
    Member
    Posted 3 years ago #

    My email actually finally came to about an hour after being sent. Not sure why it would take that long but it did work.

  21. samanders
    Member
    Posted 3 years ago #

    I have taken a fresh site that has been working before 3.2 and on version 2.4.5 upgraded the site to 3.2 and version 2.4.6 and receive the same issue, the forum icon spins and then no email is sent

    No other plugins have been changed, any suggestions?

  22. Kevin Trye
    Member
    Posted 3 years ago #

    Have the same problem and understand this is affect other forms as well. However, to make things more complicated, there is a server aspect involved. I have one site running wp3.2 with contactform7 running okay, but exactly the same theme and plugins on another host server doesn't work. But this only occurred after the 3.2 upgrade.
    Also, it's only the notification email that's not working. The reply email does work!

    Short answer is to avoid 3.2 for a while longer.... I generally wait 6 months after a big upgrade, but thought this time I'd take the risk.

  23. Spiv007
    Member
    Posted 3 years ago #

    I have the same problem. I tried with 4 different email providers.
    Running CF7 2.4.6 on WP 3.2.0
    Nothing comes in, although CF7 says it sent successfully.
    Highly annoying, since my orders are not coming in anymore.
    Takayuki Miyoshi, you should have a serious look at this if possible.

    Edit: upgrade to WP 3.2.1 didn't resolve the issue.

  24. adamleadspring
    Member
    Posted 3 years ago #

    We're also having similar problems. We currently have around 50 wordpress sites all with contact form 7 installed. Seems to be affecting sites which have been updated to wordpress 3.2 and above with contact form 7 version 2.4.6. Most of our sites are on the same server but it's only effecting sites which have been updated to the above. Please fix soon

  25. samanders
    Member
    Posted 3 years ago #

    Having done some more testing on a number of sites that have stopped working due to the 3.2.1 upgrade and 2.4.6 i have found that on the contact forms that had multi to email address fields appear to cause the issue.

    For example to field: email1@mydomain.dom; email2@mydomain.com

    Having removed the ; and second email address i am now able to receive email as long as i only have one email address to send to

    I am not sure if its the ; thats causing the issue or having two email addresses that is?!?! but either way it would be good to have a fix as i need contact forms to go to a number of users and the ; used to work fine on the old versions

    I have not tested in 2.4.6 i have only tested on wp3.2.1 and 2.4.5 plugin

    Regards,
    Sam

  26. Spiv007
    Member
    Posted 3 years ago #

    I have it also with 1 email. Tried every possible thing, the mails just don't arrive anymore.

  27. bernwa
    Member
    Posted 3 years ago #

    I wanted to update my progress with this issue. I notice that when I send test email submissions through my form they do finally arrive but it takes about an hour. I wonder what the reason for that my be? But at least I know the form is working. If anyone has any clues why it takes so long to deliver that would be great. Could it be the way my server processes it?
    Thanks

  28. JasonParkerMusic
    Member
    Posted 3 years ago #

    You may want to check your spam folder. All email sent to me through Contact 7 has ended up in my spam. Any idea how to fix this???

    jason

  29. Spiv007
    Member
    Posted 2 years ago #

    sir Takayuki Miyoshi, do you have any clue what could be the issue? I don't receive the mail in my spamfolder, they never arrived, although in the frontend it said: message sent succesful. It seems many people suffer from this since WP3.2 & CF 2.4.6

    I tried with 4 different emailproviders and my own domain, which I control the spam of. It just never arrives. I tried with using single email & multiple emails...always the same result: "sent succesful", yet never received.

  30. jamescampbell9
    Member
    Posted 2 years ago #

    Hi Members,

    I am a brand new user to Contact form 7 and I just installed the plugin and updated WordPress. The message took about 30 minutes to send after I tried to test it. Not sure how long it is suppose to take, but I thought for sure I was having the same problem as you are experiencing. My second test email still hasn't arrived yet- but I think it will.

    Maybe try it again? Maybe its working now

    James

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic