WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: Contact Form 7] Not receiving confirmation e-mail when URL is specified (1 post)

  1. Marventus
    Member
    Posted 3 years ago #

    Hello, everybody.
    First of all, I would like to say that this is a very useful and flexible plugin: thanks a lot, Takayukister!

    After reading A LOT on the plugin (Docs, FAQs, and Forum), we have managed to make it work very nicely on our blog'sContact Form. The way it's set up now, it sends out two e-mails: one to the user filling up the form, and the other one to the blog authors.

    The contact form has a field for the user to fill in his/her Site URL. During testing phase, we have come to realize that the e-mail to the author sends out fine when the URL field is left blank, but it does not when it is completed. The other e-mail (the one to the user) always gets sent, no matter whether the URL field is filled or not.

    Here is the special code we're using for the form:

    <p><span class="contactlabel">Your Name<span class="colorcur">*</span>:</span> [text* your-name class:contactfld] </p>
    
    <p><span class="contactlabel">Your E-mail<span class="colorcur">*</span>:</span> [email* your-email class:contactfld]</p>
    
    <p><span class="contactlabel">Your Site/URL:</span>[text your-url class:contactfld]</p>
    
    <p><span class="contactlabel">Subject</span>: [text your-subject class:contactfld]</p>
    
    <p><span class="contactlabel">Your Message<span class="colorcur">*</span>:</span> [textarea* your-message class:contactmsg]</p>
    
    <p>[captchar captcha-963 class:contactcapfld]  [captchac captcha-963 class:contactcaptcha fg:#AC0002 bg:#000 size:s]</p>
    
    <p><span class="requiredtxt"><span class="colorcur">*</span>  Field is required.</span></p>
    
    <p><span class="contactlabel"></span>[submit class:form_submit "Submit"]</p>

    And here are our settings:

    To: email 1,email 2
    From: [your-name]<[your-email]>
    Subject: TEBP Contact Form: [your-subject]
    Additional Headers: Reply-To: [your-email]
    File Attachments: (none)
    Use HTML Content Type: Checked

    The theme used in the blog is Thesis, which is a premium theme, and we are running on WP 2.9.2.

    Any help on this will be greatly appreciated. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic