WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
Message not sent on WP MU (10 posts)

  1. McDragon
    Member
    Posted 2 years ago #

    I have had WP on this particular server for a couple of years and the Contact 7 plugin has worked fine.
    Now I installed a MU website on the neighbouring folder. I have two websites on it and the contact 7 form does not work on either of them. It sometimes returns the Message sent ok with a green border and sometimes the message was not sent with the red border.
    I know there have been solutions for this but that was mostly because there were problems with the hosting provider's server settings.

    I wish there was a good was to debug this. On one of the websited I installed a theme (Kriesi's Coalition) that has its own contact form using the mail() function and that one doesn't work either so I think there is something in the website setting or in the WP multisite features.

    Can anybody help please.

    Bye
    Martin

    http://wordpress.org/extend/plugins/contact-form-7/

  2. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 2 years ago #

    Can you share the URL?

  3. McDragon
    Member
    Posted 2 years ago #

    Hi Takayuki

    The link to the old single site WP with the contact form that works is here:
    http://blog.martinmcdowell.com/about/contact

    The link to the new MU WP with the Coalition theme is here:
    http://petdocmartin.co.uk/#contact

    The link to the new MU WP with the default Twenty eleven template:
    http://mcdowell.si/contact/

    If required I am happy to put your email in the system as the designated receiving e-mail address. Just send me a message through the first contact form :-)

  4. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 2 years ago #

    I don't think it is a problem relating to whether it is multi site install or single site install.

    Read these FAQ topics and take measures written there.

  5. McDragon
    Member
    Posted 2 years ago #

    Hi

    I don't know what to do know. I disabled Akismet and actually all other plugins. I cannot see any server logs as but I doubt the mail is actually leaving the website host provider. I have used a few different e-mail addresses and none of them are working. The mail is not in the spam folder either.

    Martin

  6. Bastard1982
    Member
    Posted 2 years ago #

    Hi, i'm experiencing a similar issue with a normal wordpress website;

    everything's fine but no mail received; i've tried with three different e-mail addresses and no response.

    I'm also usind Sendit plugin for newsletters and mails are arriving correctly.

    Any suggestion on the nature of the problem?
    Thanks a lot

  7. McDragon
    Member
    Posted 2 years ago #

    Right. There seems to be a problem with the e-mail addresses who use my own domain and with whom I have used the Google mx records to use Google Apps to get all the mail from.
    On the server of this hosting provider I use it seems that there is some confusion in this regards as it seems to expect the namservers to be pointing to the hosting company's ones.
    Don't understand why this is so, perhaps a server configuration problem with addon domains. My knowledge is a little vague in this area.

  8. shangam
    Member
    Posted 1 year ago #

    this topic is not solved.
    n yeaaa i'm having the same problem. This post has been posted 8 months earlier. Hope that after 8 months this must have been solved by our questioners . plz any one can help with such kind of problems.

    I can see the successful msg but the mail hasn't arrived in the mail box.
    I have even tried with different email addresses.

  9. @shangam Please start your own topic with your own specific details. Replying back to a thread that's 8 months old won't get you the assistance you need.

    http://wordpress.org/support/plugin/contact-form-7#postform

  10. shangam
    Member
    Posted 1 year ago #

    Oh! thank you Jan Dembowski. I'll sure obey the way it has to be.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic