WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Contact Form 7] Gmail marking emails as spam (6 posts)

  1. brian16
    Member
    Posted 4 years ago #

    I have been using Contact Form 7 with my gmail account for about a year now with no problems. Now gmail is marking these emails as spam.

    Any suggestions on fixes?
    Why is it doing this just now?

    Thanks

    http://wordpress.org/extend/plugins/contact-form-7/

  2. Konstantin Kovshenin
    Member
    Posted 4 years ago #

    Hey Brian,

    I've been experiencing the same problem here, Gmail is not receiving any of my messages. I don't think it's a Contact Form 7 issue though, try to look into SPF..

    ~ K.

  3. mckeeverrealestate
    Member
    Posted 4 years ago #

    Hi,
    Same issue here. Does anyone have any experience with this issue? I have heard about adding an SPF record but not exactly sure how to configure...
    Thanks
    David

  4. bobegods
    Member
    Posted 4 years ago #

    This can be fixed rather easily.

    Under the "Mail" tab, change the email address in the "From" box to a recognized email (probably your own personal email would work best). And then make sure that you have the sender's email address somewhere in the message body.

    See an example image of this here.

  5. mckeeverrealestate
    Member
    Posted 4 years ago #

    bobegods,
    Thank you for your help. I have tried what you have suggested but no luck. More specifically, I am getting a 553 error, administratively denied, from the relay server.
    godaddy is telling me the name of the relay server needs to be in the code somewhere.
    See the error I am getting here.

  6. bobegods
    Member
    Posted 4 years ago #

    My first guess would be because Gmail considers that sending yourself an automated program from your own email address would be spam, so it would reject. I could be wrong but that's my guess.

    I would create a new email account on your domain and use this solely for this purpose: forms@yourdomain.com ... etc. And then use this email address in the "From" line. I've done this several times before. In fact, I set another one yesterday and it works great.

    Also, you can go into "Settings" in your Gmail account and add a "Filter" that allows you to select an email address and point it to which folder you want it to come in to.

Topic Closed

This topic has been closed to new replies.

About this Topic