WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
[resolved] Form results being sent to admin instead of intended address (12 posts)

  1. mkassowitz
    Member
    Posted 1 year ago #

    I've had Contact Form 7 start behaving strangely on three different sites, all following updates to WP 3.3.2. The form results are being sent to the admin address of the site instead of the intended address configured with the form. What's more, the responses have stopped being captured in the Contact Form 7 Database plugin I use. This issue is happening on three sites on two completely different servers with different base configurations. All have been working perfectly for months, one for years. The only changes made have been updates. Since I have the database plugin installed I can see that responses stopped being recorded after April 25. There are no common plugin updates across the three sites. The only common update between the three is WP itself to 3.3.2. Could this have caused some sort of unintended issue with CF&

    http://wordpress.org/extend/plugins/contact-form-7/

  2. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 1 year ago #

    Can I see the site? And, what other plugins and theme do you use?

  3. isaacl
    Member
    Posted 1 year ago #

    Having the same issue here - I'm using a drop menu to select the recipient, and the email is just going to the admin email address.
    The menu looks like this:
    [select* menu-847 "General Inquiry|info@domainname.com" "Advertising Inquiry|ads@domainname.com"]
    And in the To: field, I have [menu-847].
    That seemed to be working perfectly, until the latest update...

  4. isaacl
    Member
    Posted 1 year ago #

    Any update on this?
    Do you need any more info to resolve this?
    I'd like to get this working like it was originally ASAP...
    Thanks!

  5. mkassowitz
    Member
    Posted 1 year ago #

    Here's a couple of sites exhibiting this problem:

    http://organicconnectmag.com
    http://naturalvitality.com
    http://nancycartwright.com
    http://carswithcords.com

    All these sites are on completely different servers and run completely different themes.

    On this site: http://alamutt.com CF7 is working perfectly. All these sites run a wide array of plugins, too numerous to list easily. However, the 4 above have all been updated to WP 3.3.2 and the last one has not been. The last sight depends very heavily on CF7, so I have intentionally not upgraded this site.

    Hope these URLs lend some clues...

  6. isaacl
    Member
    Posted 1 year ago #

    The reply to field also seems to be behaving strangely, and when I try to reply from Gmail/Google Apps to an email sent using Contact Form 7, it has the user's info in there twice...

  7. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 1 year ago #

    Checked the four sites. The forms shown on them are actually not Contact Form 7's forms.

    I guess you're also using Jetpack plugin on those sites. Jetpack's recent update introduced its own contact form module, and because Jetpack's contact form uses the same shortcode ([contact-form ...]) as what Contact Form 7 used to use, Jetpack's contact form overrides Contact Form 7's one in certain cases.

    To avoid this issue, replace old shortcodes to new ones. You can find new format of shortcode ([contact-form-7 ...]) in the Contact Form 7's admin page.

  8. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    You can also use http://wordpress.org/extend/plugins/manual-control/ to turn off some of Jetpack's features if you would prefer to use CF7. Longer term this conflict on activation should be resolved within Jetpack.

  9. mkassowitz
    Member
    Posted 1 year ago #

    Damn. Hijacked by JetPack. I've been using CF7 for a long time and am quite comfortable with it. The solution of using the new shortcodes worked perfectly. Thanks!

  10. isaacl
    Member
    Posted 1 year ago #

    Had the same problem over here - updated and working now.
    Thanks a lot for the help!

  11. jdblundell
    Member
    Posted 1 year ago #

    Yup - I was hijacked by JetPack as well. Thanks for the info and update. Guess I better update all my sites now.

  12. stevendbg
    Member
    Posted 1 year ago #

    Hi guys, I'm experiencing something different and have several websites. I had no problems with my contact form in the side panel until the recent update. Yes I use jet pack also. I did install the plug in Manual Control for Jetpack, but I'm experiencing the same problem. The problem is only in the side bar. I even uninstalled contact form 7 and used the jetpack contact form but same problem. Below is 2 websites. The first one is the one I installed the Manual Control for Jetpack plug in.
    My 3rd site I have no problem because I have not done my updates in that one.
    1) http://homesecuritysystems-phoenix.com/
    2) http://phoenixazcommercialcarpetcleaning.com/
    3) http://floorphx.com/flooringphoenix/

    Please help

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic