WordPress.org

Ready to get started?Download WordPress

Forums

[closed] [Plugin: Contact Form 7] File Upload Limit - same old problem? (4 posts)

  1. ejuritsch
    Member
    Posted 1 year ago #

    Hello

    I would really appreciate, if somebody could help me out.
    I am trying to set up my website with a contact form that uploads pdf and doc files up to 20mb. I tried a lot of things and none work.
    (And yes I read some 30 entries with just about the same problem and it either does not work, or I do not know how to)

    Basics:
    I have a contact form with an upload function.
    I use:
    ipage hosting
    Wordpress 3.5
    Contact Form 7 (for the form)
    Simple Dropbox Upload (for the file upload - inside CF7 (but I have the same problems with the original CF7 upload field)

    Problem:
    I cannot upload files over 1MB no matter what I do. Sending and email with an attachment of under 1MB to my dropbox and/or webmail works without any problems. Everything over it, does not and I get either an unspecified "server related" error or a "file too big" error (depending on settings).
    (If I only use Simple Dropbox Upload I can upload files up to 20MB and it does work, so it should not related to a general size limit)

    The form:
    <p>Dein Name (Pflichtfeld)
    [text* your-name] </p>

    <p>Deine E-Mail-Adresse (Pflichtfeld)
    [email* your-email] </p>

    <p>Deine Nachricht
    [textarea your-message] </p>

    Welches Service interessiert dich?

    [select menu-294 "Quickcheck" "Korrekturlesen" "Lektorat" "Layout" "Anderes"]

    [file simple-wp-dropbox limit:10000000 filetypes:pdf]

    [acceptance acceptance-217] some text

    <p>[submit "Senden"]</p>

    -----
    More Info:
    I ran phpinfo.php and it gave me the following values:
    upload_max_filesize 20M
    max_input_time 60
    max_input_vars 1000
    memory_limit 128M

    I also asked ipage and they said that the email attachment can be up to 25MB.

    Any ideas? Or a work-around? Or some other great plugin that does actually work? Thank you!

    If your answer involves entering some code into php, please also tell me where I can find that file and where to insert it. (I think this would also help a lot of other people)

  2. Max Beta
    Member
    Posted 1 year ago #

    I have the same question.

    The server settings looks ok in my case too.

  3. Max Beta
    Member
    Posted 1 year ago #

    I tried now to hard code the default file size in the plugin. And it worked right away with a 5 mb limit.

    This is not a recommend method since it will be overwritten when the plugin updates. But as a testing method it was great because I could rule out any other problems.

    The settings can be found in this file:
    /wp-content/plugins/contact-form-7/modules/file.php

  4. Umair ul haq Usmani
    Member
    Posted 1 year ago #

    This is the solution..... hope you will enjoy

    You can change that setting by making a simple text file and putting it into the wp-admin folder.

    So to make this file all you have to do is open a simple text program like textedit on Mac or notepad on Windows and type these two lines of code.

    upload_max_filesize = 64M;
    post_max_size = 32M;

    You can put in any value you want I just chose 64 and 32 because they seemed like good numbers. So now you just save the file and name it php.ini the program will ask you if you want to use the ini extension, click use ini and save. Now all that is left to do is upload the file to your server and place it in the "wp-admin" folder, anywhere in the root section of the folder is fine.

    Now login to your WordPress control panel and try and upload something large. It shouldn't give you any problems and upload whatever you want!

Topic Closed

This topic has been closed to new replies.

About this Topic