WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
failed to send daily (19 posts)

  1. phillyb
    Member
    Posted 2 years ago #

    on my wordpress 3.3.1 website - http://phillybhatesme.com, i use contact form 7 for my us contact page and my international contact page.
    the form works 90% of the time or so, but once a day, i get reports that people filling out the form get the "# Sender's message was failed to send" message.
    to fix this issue, i go to my dashboard > contact form > click "save" for both of the forms > go to the pages section > and update both forms.
    no clue why this "fixes" my issue, but i'd like to be able to keep the forms up and running without having to "fix" this issue each day.

    any ideas on how to help fix this issue permanently?

    http://wordpress.org/extend/plugins/contact-form-7/

  2. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 2 years ago #

    I suppose the problem is relating to the settings of the cache plugin you use. Try making the interval of its garbage collection shorter.

  3. phillyb
    Member
    Posted 2 years ago #

    yeah you know...i always "Delete Cache" as part of my "fix" too, but forgot to mention that.
    in the wp super cache plugin, am i looking at this line to change this interval?

    $cache_max_time = 3600;

    please pardon my ignorance. this is my first website and it's obviously quite crude. talk to me as if i'm like...a 2 year old kid. lol. thanks

  4. phillyb
    Member
    Posted 2 years ago #

    any other suggestions?

  5. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 2 years ago #

    You can find WP Super Cache setting panel in Settings > WP Super Cache. Then open Advanced tab. In "Expiry Time & Garbage Collection" section, you can set the garbage collection interval.

  6. phillyb
    Member
    Posted 2 years ago #

    ok thanks. i just changed it to 1000 seconds. we'll see if that fixes me. thanks again!

  7. phillyb
    Member
    Posted 2 years ago #

    so far so good. the forms didn't go down last night. i checked them last night and today. thanks!

  8. phillyb
    Member
    Posted 2 years ago #

    NOPE!
    i can decrease the cache time even more, but i'm not certain that's the issue.
    the forms staying up was longer today than it's been in the past, so perhaps i can just get rid of the caching.
    i'm going to try and lower the cache once more and then probably delete it altogether.

    am i the only one with this issue?

  9. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 2 years ago #

    Do you still see error message? What color is its border line?

  10. phillyb
    Member
    Posted 2 years ago #

    yellow/orange
    not red
    not green
    this is the message that shows up

    http://i.imgur.com/ZUiLp.png

  11. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 2 years ago #

    Orange border. Ok. It implies that's an issue relating cache. Check the WP Super Cache's setting again, and check your site's HTML source that shows the time it's generated like this:

    <!-- Cached page generated by WP-Super-Cache on 2012-03-06 20:29:37 -->

    If it is older than 24 hours, it should show the orange border error.

  12. phillyb
    Member
    Posted 2 years ago #

    like i said, i'm brand new at this, so i looked at the plugins > plugin name > edit pages and found this

    http://i.imgur.com/ZPIgW.png

    please please please bear with me. am i looking in the right place?
    or am i way off?

  13. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 2 years ago #

    No, I don't mean it like that. I mean http://www.phillybhatesme.com/contact/ this page's HTML source.

    If you are not familiar with that, try deactivating the cache plugin to make sure if it's relating the issue.

  14. phillyb
    Member
    Posted 2 years ago #

    hmmm...interestingly enough, i see this in the source code for /contact

    <!-- Page not cached by WP Super Cache. Check your settings page. Not caching requests by known users. (See Advanced Settings page) -->

    so it's not caching at all. same with /internationalcontactform as well.

    in the advanced settings tab of the plugin, i see this - http://i.imgur.com/FpTox.png - soooooooo, even though that's a recommended setting, i'm assuming what you're asking and suggesting is to uncheck that checkbox.

    again, if i'm way off, let me know.

  15. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 2 years ago #

    Once logout WordPress, then check it again.

  16. phillyb
    Member
    Posted 2 years ago #

    logged out and back in. now the /contact page says
    <!-- Cached page generated by WP-Super-Cache on 2012-03-07 08:00:40 -->
    at the bottom.
    the checkbox for "don't cache pages for known users" is still unchecked.
    we'll see how it goes today

  17. phillyb
    Member
    Posted 2 years ago #

    same problem, rechecked "don't cache pages for known users"
    logged out and logged back in, went to the /contact source code and saw, "<!-- Page not cached by WP Super Cache. Check your settings page. Not caching requests by known users. (See Advanced Settings page) -->"

  18. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 2 years ago #

    When you see the problem, logout and check the /contact HTML source.

  19. phillyb
    Member
    Posted 2 years ago #

    i generally check/confirm from my phone. not sure if i can grab the source from there and it always works from my computer since i guess i'm logged in.
    i'll log out next time and check the source code.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic