WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
[resolved] Email with attachment can't get through (6 posts)

  1. smoon17
    Member
    Posted 1 year ago #

    Hello,
    I've got a problem when I'm trying to send mail with attachment.
    This mail is never received and the message is : 500 line limit exceeded.
    I understand this is a problem with the line length.
    I found some answer concerning the wordwrap, encodind and the function chunk_split, but my problem is that I'm not at all a specialist in php, and I can't find the place where to write a code to make it work, and I'd like to find the specific code to write.
    I'm trying to find an answer for days, and I really need help.
    I'm sure this is quite simple.

    http://wordpress.org/extend/plugins/contact-form-7/

  2. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 1 year ago #

    the message is : 500 line limit exceeded

    What message is this?

  3. smoon17
    Member
    Posted 1 year ago #

    This is the answer I receive in my mail box. It means my contact form or my newsletter could't be send, and the reason is :
    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients.

    The mail system

    <xxx@xxx.com>: host xxxxxx.com[] said: 500
    Line limit exceeded

    It seems that the mail content is read as a single line, so this line is more than 1000 chars when there is an attachment like image or newsletter, so the mail is rejected.

    I hope I am clear enough, english si not my mother's tongue, php language is not neither...

  4. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 1 year ago #

    What other plugins and theme do you use? What happens if you deactivate all other plugins and switching to the default theme? WordPress itself can handle email with image attachments, and Contact Form 7 doesn't affect it.

  5. smoon17
    Member
    Posted 1 year ago #

    The web site is not online yet, so I tried with an other site which is online, and it seems that everything works well. I've got this problem ony when I'm working on the site with localhost.
    So finally everything's fine, even if I still don't understand why it doesn't work with localhost. But it is certainly due to my lack of knowledge in programmation and php code.
    Maybe you could give me an explanation.
    If not I will close this topic.
    Thank you anyway for your quick questions.

  6. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 1 year ago #

    Probably it is a mail server issue on your local environment.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic