WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Contact Form 7] Does not go back to same page after submitting form (8 posts)

  1. kilzac
    Member
    Posted 5 years ago #

    Hi,

    Heres the page i have the Contact Form 7 on :

    http://www.exotic-styles.com/?page_id=14

    After submitting the form, the content gets mailed, and it re-directs to the same url, BUT shows a non-existing page. This non-existing page is actually an empty single.php template file. It all seems to get mixed up after submitting the form somehow.

    I've been trying to solve this conflict but haven't found a clue.

  2. Samuel B
    moderator
    Posted 5 years ago #

    generate your permalinks
    admin - settings - permalinks

    http://codex.wordpress.org/Using_Permalinks#Choosing_your_permalink_structure

  3. kilzac
    Member
    Posted 5 years ago #

    i've tried changing to other permalink formats and still not fixing this issue. besides i can't use other permalink structure as i'm using the ID numbers parsed at the URL to update certain graphics in the template.

  4. kilzac
    Member
    Posted 5 years ago #

    update : i've tried everything i can set at the permalink section and still, its the same. I've used Contact Form 7 on other sites before, and they were all fine, and were using just the default permalink structure.

    i appreciate all the tips and help i can get from here. totally clueless right now.

  5. Takayuki Miyoshi
    Member
    Posted 5 years ago #

    @kilzac what browser did you use? Can you test with another browser?

  6. kilzac
    Member
    Posted 5 years ago #

    Firefox. tested with Google Chrome and IE 8 as well. same thing happened.

  7. gordonmurray
    Member
    Posted 5 years ago #

    I'm having this problem too.

    When I fill out my form it sends the details to my email but on the screen it says "No Posts Found. Sorry! We couldn't find what you were looking for ..."

  8. Takayuki Miyoshi
    Member
    Posted 5 years ago #

    @kilzac can I ask you what HTTP server is working? Apache? IIS?

Topic Closed

This topic has been closed to new replies.

About this Topic