WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
Contact Form not sending mail (44 posts)

  1. Richjordan
    Member
    Posted 2 years ago #

    Hi Guys,

    Please be gentle as I am new to this forum. I was hoping that someone would be able to help me.

    I have a problem with a contact form on a website, when i click submit, its won't send, and then gives me the following error -

    "Failed : some issue occur while sending your message"

    I'm not sure where to start with this one.

    Any advice would be huuuuuugely appreciated.

    Thanks,
    Rich.

    http://wordpress.org/extend/plugins/contact-form-7/

  2. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 2 years ago #

    Where is the site?

  3. annawelsch
    Member
    Posted 2 years ago #

    I am also having an email issue with a form, slightly different - when the form is submitted on my site, I get the message "Thank you for contacting us" and it shows up in the entries on my site. Problem is, the forms are not being emailed to me. I've tried both my godaddy account and my gmail account - neither is getting the emails. I just got off the phone with godaddy and was told my server is working fine. Also, the forms were being emailed just fine up until about a week ago - then, without me changing anything, they just stopped.

    Any thoughts? I've seen forums from several years ago that had this same problem, but those answers were for much earlier WordPress versions...

  4. opticalfuel
    Member
    Posted 2 years ago #

    Is this plugin working for anyone else with WP ver 3.4? I have identical forms and plugins setup on TWO sites.... one WP 3.3.2 works fine, while the other WP 3.4 will not send emails. (I never receive the email.)

    Methinks there might be a bug in the soup.

  5. dodangtien
    Member
    Posted 2 years ago #

    So do I. I use WP 3.4 and I never get the message from Contact form 7 although it says "Your message was sent successfully. Thanks.". I tried to change hosts or do anything with the hopw that Contact form 7 works.

  6. Gerdt
    Member
    Posted 2 years ago #

    Same kind of issue, send succesfully but do not receive it.
    The automatic thank you mail (mail 2) is received however at sender.

  7. annawelsch
    Member
    Posted 2 years ago #

    I desperately need this resolved. Is this a WP 3.4 issue?? Do we just have to wait until they fix it?

  8. Gerdt
    Member
    Posted 2 years ago #

    I got it working but no idea how. I use 3.4 so that is not the issue

  9. Gerdt
    Member
    Posted 2 years ago #

    I got it working but no idea how. I use 3.4 so that is not the issue

  10. annawelsch
    Member
    Posted 2 years ago #

    Gerdt - what did you do??? Please advise!!

  11. Gerdt
    Member
    Posted 2 years ago #

    Well, I figured out the mail can be received by outlook and not by gmail.
    Still strugling why

  12. hudey123
    Member
    Posted 2 years ago #

    It's a WordPress 3.4.1 and Gmail issue - no messages will send from WordPress (comments, contact form 7, or anything) when it's sending to a gmail.com or Google Apps - hosted domain. I'm assuming WP and Google are working on this already and it will be fixed soon.

  13. hudey123
    Member
    Posted 2 years ago #

    Ah, correction. It will work from my domain (google apps hosted) if I set CF7 to send to my regular gmail.com address. But it won't work from my site (at my domain) - to my google apps email for the same domain. So for instance:

    my-wordpress-site.com > contact form 7 > me@my-wordpress-site.com (NOT working if me@my-wordpress-site.com is hosted at google apps)

    my-wordpress-site.com > contact form 7 > me@gmail.com (YES)

    my-wordpress-site.com > contact form 7 > me@hotmail.com (YES)

  14. annawelsch
    Member
    Posted 2 years ago #

    My forms are self-made - not just the contact form. For some reason, tried it today - it's working! WP must have figured it out. The forms are coming into my godaddy email account...

  15. Yattaa
    Member
    Posted 2 years ago #

    Thanks hudey123 man. Works fine for me.

  16. Allisons
    Member
    Posted 2 years ago #

    I've been having a similar problem, the Contact Form 7 page appears to work fine, but 90% of the time no email is received. I've done all the FAQ stuff, and this form used to work perfectly. Has anyone got this working that isn't using gmail?

  17. hapke
    Member
    Posted 2 years ago #

    Contact form 7 shows an error message and does not send mails, but on some websites (on the same server) it works. I have updated WP to 3.4.1. I have deactivated all other plugins - no solution.

  18. Miriam de Paula
    Member
    Posted 2 years ago #

    I have the same problem. already installed the WP Mail SMTP plugin, but still does not work. I get no e-mail sent through the CF7.

    Please developer, you could help us with any tips?

    thanks!
    Miriam de Paula
    http://wpmidia.com.br

  19. hapke
    Member
    Posted 2 years ago #

    @Miriam: Try the following:

    • update WP to 3.4.1
    • deactivate/reactivate the plugin
    • delete your old form and create a new one
    • embed it and try again

    I was successful now (WP 3.4.1).

  20. wavydavey
    Member
    Posted 2 years ago #

    Hi Folks,

    I made a little discovery that may help your gmail issues.

    I couldn't get the form to send to my Google Apps gmail account, but it would send to my btinternet.com account. When I hit reply (from within btinternet.com) I found that the reply-to email was not coming in correctly. Checking back on my form, I found that the "ContactEmail" field in the "Mail > From" box was missing a capital letter, divorcing it from the form data. Once this was fixed the emails starting coming through to Google Apps Gmail, and all was sorted.

    Hope this helps someone!

    cheers

  21. time-trooper
    Member
    Posted 2 years ago #

    I have tried SMTP, deactivating plugins, reinstalling contact form 7 plugin, i've tried every advice I found but nothing works.

    Suddenly, a week ago, I stopped receiving emails from my forms, nothing happens when I click the submit/send button, not even the success/error message appears, it only reloads the page.

    I don't know what to do. :(

    I'm trying to send emails to a google account, and the site is hosted on godaddy (linux). Some people have posted that godaddy blocks some functions for sending emails. Don't know if that's true, I talked to them but they gave me no solution.

    I'm not the best at programming PHP, I'm learning as I go, I know how to edit the code but I don't know if the plugin uses class-phpmailer.php or wp-mail.php.

    I don't understand why it just stopped working, my client is desperate. Need your help!

  22. gal_op
    Member
    Posted 1 year ago #

    Any one figured out how to solve this?

  23. Avi Chitranshu
    Member
    Posted 1 year ago #

    sir....when i send a mail through contact-form7 any type(gmail/rediff/yahoo etc). its shows send successfully but mail not recevied why?

  24. Avi Chitranshu
    Member
    Posted 1 year ago #

    sir/madam...
    no one help me , why?

  25. Avi Chitranshu
    Member
    Posted 1 year ago #

    sir ....
    i have also faced same issues .when i send a massage through cf7 ,result shows successfully mail send but i can't receive any mail.
    my site

  26. steveamadeo
    Member
    Posted 1 year ago #

    @hapke

    "Try the following:

    update WP to 3.4.1
    deactivate/reactivate the plugin
    delete your old form and create a new one
    embed it and try again"

    Finally! Thanks so much for posting the tip. My contact form finally works.

    Note: I'm also using Configure SMTP plugin for quick and easy set up of gmail within wordpress http://coffee2code.com/wp-plugins/configure-smtp/

  27. designrox
    Member
    Posted 1 year ago #

    I tried all of these things and my form still does not work. Someone please help.

  28. sooooophi
    Member
    Posted 1 year ago #

    I have 4 forms on my site and none works suddenly.
    Please help!!

  29. sooooophi
    Member
    Posted 1 year ago #

    I don't know if it has anything to do with it, but I add removed the <> around the email and now that put it back, it seems to work again.

  30. designrox
    Member
    Posted 1 year ago #

    @sooooophi I tried what you mentioned but that didn't work for me. My forms still don't deliver to my email. :(

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic