WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
CF7 says mail sent, but no mail ever arrives (21 posts)

  1. gsrvuk
    Member
    Posted 2 years ago #

    Contact Form 7 (latest version) appears to work. If you set up a form and then enter data into that form and hit send, it says that the message has been sent but no message ever arrives at the destination.

    What could be stopping it from sending and how might I track down what the problem is? Is there an error log or any test I could perform to see what is the matter?

    http://wordpress.org/extend/plugins/contact-form-7/

  2. rmassart
    Member
    Posted 2 years ago #

    I am having this same problem and it seems to be related to sending to an address in the WordPress system.

    eg: if I set the send to email to be the WP admin email, I never get the email. If I set the send to email to be a different one (not associated to a WP User) I get the email.

    Is there a way to enable sending to emails of WordPress Users?

    Thanks.

  3. rmassart
    Member
    Posted 2 years ago #

    Apologies, this is now working for me. But for some reason the mail took several hours to arrive.

  4. jason@theonlinemarketer.co.za
    Member
    Posted 2 years ago #

    Hi Please Help

    I am having the same problem. I set up the uploader option and find that although it says SENT I never get the email.

    I am using the latest version of contact form 7

  5. jason@theonlinemarketer.co.za
    Member
    Posted 2 years ago #

    Hi

    So I did a little reading and found this...

    http://contactform7.com/blog/2009/11/24/file-uploading-and-attachment/
    "The location of the temporary folder depends upon your settings in WordPress. Open the Settings > Miscellaneous (Settings > Media if you use WordPress 3.0 or higher) menu, and check the setting for Store uploads in this folder field. The default is wp-content/uploads. Normally, Contact Form 7 creates a wpcf7_uploads folder in this location and uses it as the temporary folder for any uploaded files"

    I Checked to see if the "wpcf7_uploads" folder was created and it was. Inside the "wpcf7_uploads" folder I found a .Htaccess file with "Deny from all".

    I uploaded a file and sent the message using the CF7 on my website but found the attached file doesn't show up in the temp folder "wpcf7_uploads"

    Any Ideas?

    Thanks

  6. sethfam
    Member
    Posted 2 years ago #

    I'm having this same problem--and I'm not offering file uploading as part of the contact form.

    I've tested with two different forms and with multiple email addresses but nothing seems to work.

    Any ideas or advice?

    Thanks!
    Seth

  7. JeffersonJ
    Member
    Posted 2 years ago #

    I'm having the same issue with two sites and they does not include the upload field! One of the sites has a Contact Form that has been previously working for months! I'm in kind of an urgent situation as well where I need another iteration of the contact form to be working for an event tomorrow. I've been testing it all day too, so it's not just being delayed at this point

    Can everyone please check that their contact forms are working and let me know?

    I'm not sure if there is a central server that the emails go through, but perhaps something central is currently down.

    http://www.vrf-marine.com
    http://www.alabamaductless.com

  8. sethfam
    Member
    Posted 2 years ago #

    I actually figured out what was wrong. It had to do with the fact that I'm using Gmail to run the email for the domain WP is installed on, and so you can't use the standard php mail() function to send emails via Contact Form 7 or ANY other contact form program.

    Here's the solution:

    1. Install the wp-smtp-mail plugin onto your WP site.

    2. Follow the directions on http://www.callum-macdonald.com/code/wp-mail-smtp/ to configure the plugin properly (I used the Gmail/Google Apps settings contained on this page to properly configure the plugin for my domain)

    3. Send yourself a test email using the plugin. When things are setup properly, the email actually sends and it (almost) instantaneously appears in your inbox. From there CF7 and other contact functions should work flawlessly.

  9. JeffersonJ
    Member
    Posted 2 years ago #

    Wow, thanks sethfam. That was the issue.

    What's strange is that Contact Form 7 used to work flawlessly to my Google Apps account without the other plugin. It makes me wonder if I've missed any business from it!

  10. weiyunet
    Member
    Posted 2 years ago #

    I got the same problem too.

    I installed the wp-smtp_mail and i can send a test mail. But just not work for contact form 7!

    according to the WP-smtp-mail FAQ, it was due to:

    No email from plugins?

    If you’re using plugins to send email, these plugins will ignore the SMTP settings if they call PHP’s mail() function directly. If you see the function mail() and not wp_mail() in the plugin’s source, that’s the problem. You should be able to simply add wp_ in front of the existing mail command and it will probably work! (Insert lawyer-speak no warranty blurb here!)

    Can any body tell me which folder and which file should I edit? i cannot handle it. Thank you.

  11. JeffersonJ
    Member
    Posted 2 years ago #

    Weiyunet, I didn't have to edit the plugin, as the instructions state. It worked for me right away. In fact, it even sent all of the backlogged entries in the contact form, some dating as far back as a month ago.

  12. nheasley
    Member
    Posted 2 years ago #

    I'm using google apps to manage my domain, but I can't seem to get the Callum instructions to work. I set the smtp and everything, but which email address should I be using here? I have my domain account, and that is forwarded to my main gmail account. If I use my domain account, what would that look like - I mean, is it nheasley@domain.com instead of nhealsey@gmail.com?

    Sorry if that's all a bit confused, I've been working on this site all day and my brain is fried. :(

  13. nheasley
    Member
    Posted 2 years ago #

    I've tried it six ways from Sunday; using the domain address, using my other gmail address, with POP enabled, etc. Nothing works. Getting error message:

    ["ErrorInfo"]=>
    string(43) "SMTP Error: Could not connect to SMTP host."

  14. jason@theonlinemarketer.co.za
    Member
    Posted 2 years ago #

    Hahahahah Success!!! @ nheasley make sure you select - under "Authentication" Yes: Use SMTP authentication.

    you can use nhealsey@gmail.com below are the steps

    Gmail / Google Apps

    To send email via Gmail or Google Apps, use these settings:

    Mailer: SMTP
    SMTP Host: smtp.gmail.com
    SMTP Port: 465
    Encryption: SSL
    Authentication: Yes
    Username: your full gmail address
    Password: your mail password

  15. nheasley
    Member
    Posted 2 years ago #

    Everything is set right, but I still get a "could not connect to SMTP host" error.

    Maybe it's something to do with my host. I'll give GoDaddy a call later today.

  16. weiyunet
    Member
    Posted 2 years ago #

    My error has not yet fixed.
    I could send test mail from WP-SMTP-Mail.
    But just could not receive the contact form 7 and any other contact forms.

    Some body suggested to put a line in a .css file in the root.
    # PHP - MAIL
    php_value mail.force_extra_parameters -your_email_address

    But I dont know where and how.

    Can any body help?

  17. nheasley
    Member
    Posted 2 years ago #

    I reversed course and tried using the PHP mail function rather than the SMTP, and I was actually able to get a test email with the right "from" address, though I have not been able to get any of the forms to send an email even though I get the "email sent" message from the form.

  18. jason@theonlinemarketer.co.za
    Member
    Posted 2 years ago #

    True - there is something that I noticed now when using the contact form 7 going through my gmail address. When someone sends an info request through my form the email says FROM: that persons Name (good) and then uses my email address theonlinemarketerel.co.za (bad)

    I want it to put their email address in (like it should) so that I can reply without having to take out my email address or the email address that the form is running through!!!

    Normally you put in these tags [your-name] <[your-email]> and it captures the email address from the form.

  19. jason@theonlinemarketer.co.za
    Member
    Posted 2 years ago #

    oh I meant going through my gmail address using the plugin suggested above to run Contact form 7

  20. keithkarr
    Member
    Posted 2 years ago #

    @ sethfam...Where do I send the check!

    You rock!

  21. ssalenger
    Member
    Posted 2 years ago #

    @sethfam that worked for me too! Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic