WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
[resolved] CF7 does not recognize the [your-email] tag, reverts to noreply@[mydomain]! (3 posts)

  1. Shrikant Joshi
    Member
    Posted 3 years ago #

    The title says it all.

    I am running the latest CF 7 on a WP 3.0.3 installation with BP 2.x on a Pagelines template (integrated). I have also setup Google apps mail and that's where I think I committed the HUGE boo-boo. Recently, the "From" address in the mails began to display the default address: noreply@[mydomain]

    I edited the settings to include the [your-email] tag in the message body and the tags are correctly replaced there. It seems that the "FROM:" headers in the outgoing mail are not being recognized/accepted by the Google Apps Mail.

    Help, please? :(

    http://wordpress.org/extend/plugins/contact-form-7/

  2. Shrikant Joshi
    Member
    Posted 3 years ago #

    ...and another thing!

    The second mail - to be sent to the user submitting the form - also doesn't get sent. This might mean that Google Apps Mail is conflicting with the default SMTP settings.

    Now I am not a developer - just someone who hacks his way around the platform with a LOT of help from the support forums & some basic knowledge of the platform. If you could guide me in some way it would be much appreciated!

    Thanks in advance! :)

  3. Shrikant Joshi
    Member
    Posted 3 years ago #

    SOLVED.

    I had completely forgotten to add the relevant MX records for the Google Apps Mail in my domain management service. Once I did that, everything worked like a charm!

    I don't have the tech explanation for it, but I can see how it works - can't explain it, though! :)

    Posting this, so that if anyone else has the same problem, maybe this could be your solution, too! :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic