WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: Contact Form 7] Can't send emails to its own domain (7 posts)

  1. JohnnyN05
    Member
    Posted 3 years ago #

    Hello there,

    So I've done my research here and on Google, and found nothing that helps me. At least not an actual solution. I know the answer is out there, but I can't seem to find it.

    Anyway, here's my problem:
    Contact Form 7 does not send an email that contains the same domain name as the actual site name. It sends everywhere else but there. The email in question uses Google Apps. It sends to other Google Apps emails, but not the one of the site domain name. The site is not hosted with GoDaddy, so we can rule that out. The host we are using does use cPanel. So if I need to do anything in there, I can. I've tried WP-Mail and entered SMTP settings for gmail and no dice.

    Is this a hosting problem, plugin problem, wordpress problem, Gmail problem, or just me?

    Thanks!

  2. stvwlf
    Member
    Posted 3 years ago #

    This is most likely a hosting mail configuration issue. Contact your webhost.

  3. mrosner
    Member
    Posted 3 years ago #

    JohnnyNO5: This is the exact problem I'm having. Were you able to find a solutions? Thanks!

  4. JohnnyN05
    Member
    Posted 3 years ago #

    @mrosner - Yes and no..This actually was my web host company. I called them up and they fixed it.

    For my hosting company, when you add a domain to host with them, all requests for that domain checks its own DNS. So when WP sends an email, their network checks their own DNS and of course their DNS doesn't have google as the MX record.

  5. Jenn
    Member
    Posted 2 years ago #

    Digging up an old post here...

    I use a different host for email than I do for my website. Is the problem with the email host or the web host?

  6. rabbid
    Member
    Posted 2 years ago #

    Having the same problem here. What is the correct solution? Thank you

  7. Andrew Tegenkamp
    Member
    Posted 2 years ago #

    I know this is old, so hopefully figued out, but generally you need to contact your web host. If your host has CPanel you can go to "MX Entry" and enter the information there or just contact your host and tell them your email is hosted elsewhere.

    Your email provider should have the MX values you need. For example, Google Apps (GMail for your domain) has theirs at http://support.google.com/a/bin/answer.py?hl=en&answer=143444#configure (option: I can't configure my MX records).

    If you can get email when it is sent normally but you have probably made the changes at your Registrar (name.com, etc) correctly. If you cannot get mail from your website to your domain as described here, those changes probably need to made at your host (BlueHost, DreamHost, etc like http://wordpress.org/hosting/).

    Basically, the host says "oh, we host yourdomain.com and it is sending email to yourdomain.com so no need to go out to the internet, we can handle it internally" when in fact you need that internal mail to go out because your email is NOT hosted there.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.