WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
[resolved] Call to undefined function wpcf7_add_tag_generator (19 posts)

  1. jcmilton
    Member
    Posted 1 year ago #

    I just updated (automatically) to version 3.2. Now all of a sudden I cannot upload images using NextGEN Gallery.

    When I try to upload I get this error:

    ERROR: sample-image.jpg:
    Fatal Error: Call to undefined function wpcf7_add_tag_generator() in /home/xxxx/public_html/wp-content/plugins/contact-form-7/modules/text.php on line 152

    The end result is that no images are uploaded. But if I disable the Contact Form 7 plugin, the NextGEN Gallery upload works again. So there is a conflict in there somewhere with the latest version 3.2.

    Any help would be appreciated!

    Thanks!

    http://wordpress.org/extend/plugins/contact-form-7/

  2. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 1 year ago #

  3. Stefan Martinek
    Member
    Posted 1 year ago #

    The same problem: after upgrade of Form 7, I get conflict between NextGEN & Form 7. I am new to WordPress and decided to recover the old version of my website than to waste time. Maybe it is best to wait for a few weeks before rushing into plugin updates.

  4. jcmilton
    Member
    Posted 1 year ago #

    OK I tried the development version and now I get this error message on my MAIN WP ADMIN PAGE, which is a bit scary.

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'wpcf7_add_tag_generator_captcha' not found or invalid function name in /home/xxxxx/public_html/wp-includes/plugin.php on line 405

    Is there any way I can simply revert back to the previous version of Contact Form 7. It was working fine and didn't create all of these error message. I could not find an archive of previous versions. Are older versions available somewhere?

  5. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 1 year ago #

    You can download old versions from here.

    http://wordpress.org/extend/plugins/contact-form-7/developers/

  6. jcmilton
    Member
    Posted 1 year ago #

    Thank you. I reinstalled 3.1.2 and the NextGEN Gallery upload works again.

  7. Takayuki Miyoshi
    Member
    Plugin Author

    Posted 1 year ago #

    I guess the call_user_func_array() warning is just a one-time issue on switching versions.

  8. ukmgranger
    Member
    Posted 1 year ago #

    I too am having the same problem. Unfortunately I have had to drop back to an earlier version.

  9. mintfactory
    Member
    Posted 1 year ago #

    Same here. Reverted back to 3.1.2 and can upload images to NEXTgen again but no way to do it with latest CF7

  10. brian317
    Member
    Posted 1 year ago #

    Yes same issue exactly. Reverting via link above.

  11. rolito
    Member
    Posted 1 year ago #

    Hello Takayuki Miyoshi

    When do you expect to launch a new Contact Form version to avoid the conflict with NextGen Gallery?

    Thanks!

  12. It is an issue with the NG Gallery. I had the same issue with my plugin and needed to make an adjustment.

    You have to edit ngg-config.php.

    Find:

    require_once( WP_LOAD_PATH . 'wp-load.php');

    Replace with:

    require_once( WP_LOAD_PATH . 'wp-admin/admin.php');

    This will allow you to use the latest releases of both plugins.

  13. blackriver
    Member
    Posted 1 year ago #

    This helped, thanks a lot. Who is going to fix this NG or CF7? ;)

  14. Jenn
    Member
    Posted 1 year ago #

    If we edit the ngg-config.php file, will the changes get overwritten with the next plugin update?

  15. achensee
    Member
    Posted 1 year ago #

    I can confirm this issue on our websites.
    @Josh - thanks for the fix.
    @blackriver - good question ;-) they opened a thread at the ngg plugin support: http://wordpress.org/support/topic/plugin-nextgen-gallery-conflict-with-contact-form-7

  16. @blackriver,

    NGG needs to fix their core file. I had the same problem with my plugin (Ultimate Tinymce). I wasn't aware of the improper call during the page rendering sequence until my plugin conflicted with CF7. Fixing my code made both plugins function perfectly. NGG needs to do the same.

    @Jenn,

    Yes. The change will be overwritten the next time you update the plugin. Hopefully, however, it will be addressed in the authors next release. Be sure to watch the changelog to see if it is mentioned.

    @achensee,

    My pleasure :)

  17. theR3AP3R
    Member
    Posted 1 year ago #

    @josh you're a life saver!

    I have a client meeting in 20 min and the next gen gallery was the last thing on my list to instal and tweak.... Imagine the horror when I tried to upload 30+ images.

  18. Andrew.Bloom
    Member
    Posted 1 year ago #

  19. dj10bear
    Member
    Posted 1 year ago #

    THANKS the above link worked for me fixing nexgen gallery ERROR when uploading images to a gallery: "require_once( WP_LOAD_PATH . 'wp-admin/admin.php'); etc....

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.