WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: Contact Form 7] All emails coming from admin@mysite.com (35 posts)

  1. buskerdog
    Member
    Posted 4 years ago #

    I think there was an upgrade recently, right? All emails are now coming from admin@mysite.com and not from the email addresses entered by the users. I've lost the contact information from the people who emailed me while this was going on. I just added [your-email] to the subject and message body as a stopgap measure but that's not really a solution. What's up?

  2. kiwia
    Member
    Posted 4 years ago #

    I'm having the same problem, all emails are picking up my admin email address as the sender and not the actual user sending me an email via the contact form?

  3. Takayuki Miyoshi
    Member
    Posted 4 years ago #

    I often hear the issues like this. Most of them are caused by other plugin which changes the sender address. For example, MailPress plugin causes this kind of issue. There is no workaround but deactivating one of them.

  4. SnakeEater
    Member
    Posted 4 years ago #

    I have the same problem, and I don't have other mail plugins....

    HELP!!!

  5. SnakeEater
    Member
    Posted 4 years ago #

    Guys, I found a way to avoid the problem:

    Go to the Settings page of Contact Form 7. In the body form, you have to put this:

    [your-name]

    [your-email]

    [your-message]

    in this way, you will see Name and Email in the body of the mail, without any problem

    Hope to be useful

  6. Michael Shedd
    Member
    Posted 4 years ago #

    thanks snakeeater u rock!

  7. luxulyan
    Member
    Posted 4 years ago #

    Dear SnakeEater,

    Not being very clever on this, still cannot work it out. Finally managed to get Contact Form 7 to send emails to me but not receiving any of the content. Please help, nealy lost all my hair.

  8. taebp
    Member
    Posted 4 years ago #

    luxulyan - This may just be obvious and may not help you but it took me a few minutes to see it. When you are on the "Settings" page for the contact form, the first section is the "Form" section. Below that is the "Mail" section. In the mail section, on the right hand side you will see a text box to enter information for "message body". In that section enter the following three items:

    [your-name]

    [your-email]

    [your-message]

    I hope that helps!

  9. drkknght
    Member
    Posted 4 years ago #

    i get this problem, as well.

    SnakeEater's fix is a clever one, and it does work (showing the user's name and email within the body of the message) but i'd prefer if the user's name/email address were in the "from" field of their email when it arrived, rather than "admin@..." from my domain.

    is this perhaps a conflict with something? or just a bug i'm not smart enough to know about :)

  10. aredorange
    Member
    Posted 4 years ago #

    same problem here... yes, you can get away with it putting that info on the body of the email but that is a away to get away with it - the problem is still there: the From is supposed to have the email of the sender and not the admin@mysite.com...

  11. madeglobal
    Member
    Posted 4 years ago #

    This may not fix everyone, but wp-mail uses a filter which can be "hijacked" by any other plugin. I had the same problem and found that the sending (from) email address was being set up by simplepress forum... overriding any other settings for the send address.

    My suggestion is to look at all of your other plugins and see if any of them are in control of the send email address.

    Hope it helps.
    Madeglobal.com

  12. CoastalData
    Member
    Posted 4 years ago #

    Hahaha, I had this problem too, but I just noticed that I had the "mailfrom" plugin attached, that that's the only thing that plugin does is to override the from address! Removed it, and all fixed now!

  13. Brimfulof
    Member
    Posted 4 years ago #

    I'm having the same problem, and given that I have simplepress forum installed I guess that's the issue, but is there anything I can do about it? I don't want to uninstall either plugin.

    Madeglobal - do you have any ideas?

    Thanks.

  14. becken
    Member
    Posted 4 years ago #

    I have the same issue as Brimfulof.

    I have also SimplePress installed, and can't just disable it.

  15. Marceau
    Member
    Posted 4 years ago #

    Hi,
    Same problem but i don't use Simple Press so it must be something else...
    Workaround:

    Add this to the header:

    CC: [youremail]

    That way you'll have to "reply to all" instead of reply but it works until this case is resolved...

  16. Marceau
    Member
    Posted 4 years ago #

    Better workaround:

    Add this to the "header":

    Reply-To [youremail]
    Reply-To:[youremail]
    Reply-To: [youremail]
    CC: [youremail]

    Note: ("youremail" or "your-email", or whatever you use)

    As you will see, if you reply to the email, you reply directly to the good sender (ok your email is still sent from admin@yourblog.com) but it's not really important).

  17. touchstoneweimaraners
    Member
    Posted 4 years ago #

    Please help! I am having the same problem, but I cannot get the workarounds to work either. I put
    [your-name]

    [your-email]

    [your-message]

    in the message body and it only shows the message, not the other information.

    I also added
    CC: [youremail]

    and nothing showed up in the cc field.

    What am I doing wrong?

    I do have simplepress on my site also.

    Thank you!

  18. tnorberg
    Member
    Posted 4 years ago #

    I have gotten so sick of trying to figure a way out of this jam...And then Marceau came around with the brilliant work-around...Thanks!!!!

    Just a side note Add code to "additional headers" section.... I got lost lol:

    Reply-To: [your-email]

    Works like a champ because I had to copy and paste all emails from users to make it work before.... But hopefully this issue "gets fixed" properly for next version...

    Tom

  19. gep78
    Member
    Posted 4 years ago #

    People, definitely you have another plug-in overwriting this setting!! Like CoastalData I had mailform plugin installed. I disabled it and it is working! Brilliant. Thanks CoastalData

  20. budtheteacher
    Member
    Posted 4 years ago #

    Good afternoon. We are running into the same problem of the admin e-mail showing up as the sender. Is there a way to determine what plugin might be overriding the form, or do we have to guess and check? We've turned off every plugin that we can find that touches mail - and still no success. We're running this plug-in in WPMU version 2.6.

    Any suggestions would be much appreciated.

  21. svedman
    Member
    Posted 4 years ago #

    (deleted)

  22. svedman
    Member
    Posted 4 years ago #

    I'm having the same problem as described in this thread.

    The biggest problem is that the developer of this plugin, Contact Form 7, says it's the other plugin's fault, while the developer of the plugin that cause this plugin to fail like described here says it's Contact Form 7's fault.

    So nobody wants to fix it... :(

  23. Marceau
    Member
    Posted 4 years ago #

    Ok, let's have a look at all our posts to sum up:

    I don't use ANY of the plugins up there:
    - MailPress
    - mailform
    - simplepress

    Maybe it's a WP problem ?
    I have noticed that WP now uses PHPMailer Version: 2.0.4: This is new, older releases used 2.02

    Maybe it's a Windows problem ? I use a windows server to host my blog (yes i know it's a shame but...) ;)

    I've tried to use :
    - Cimy Swift SMTP => same problem
    - WP-Mail-SMTP => same problem
    So i deactivated both.

    My WP version: 2.8.4

    Activated plugins:

    Akismet
    Contact Form 7
    Dagon Design Sitemap Generator
    Donate Plus
    Global Translator
    Google Analytics for WordPress
    Google XML Sitemaps
    Joe's Quotes
    podPress
    Really Simple CAPTCHA
    Redirectify
    Role Manager
    ShareThis
    SI CAPTCHA
    Simple JQuery Lightbox
    Subscribe2 <=maybe it's this the faulty one ?
    Subscribe To Comments
    Theme My Login
    WordPress Database Backup
    P-PageNavi
    WP-Print
    WP-Stats
    WP-Sticky
    WP-UserOnline

    Do we have an activated plugin in common ?

    Regards.
    M.

  24. Marceau
    Member
    Posted 4 years ago #

    Folks, i've found the faulty plug-in:

    "Theme My Login" 4.2.1

  25. Jeff Farthing
    Member
    Posted 4 years ago #

    It is indeed my plugin "Theme My Login". What I did was apply a filter over all of the site e-mails, instead of just the e-mails sent by the plugin. I guess I wasn't thinking clearly about conflicting with plugins like Contact Form 7 and such. I will issue a fix (4.2.2) ASAP.

  26. Takayuki Miyoshi
    Member
    Posted 4 years ago #

    @jfarthing84 thank you for the information.

  27. Marceau
    Member
    Posted 4 years ago #

    Thanks again jfarthing84: New release of your plugin activated, tested and approved !

  28. digitz
    Member
    Posted 4 years ago #

    @takayukister,

    The new CF7 update had broken the emails being sent.
    Now all emails are coming from wordpress@mysite.com but they are all blank.

  29. thaimerits
    Member
    Posted 4 years ago #

    Thank you. this plugin work for me.

  30. Takayuki Miyoshi
    Member
    Posted 4 years ago #

    @digitz the newest version is working on my site and I haven't recieved any trouble reports of similar kind issues so far. Are you sure any other plugins or server side issue are not related to it?

Topic Closed

This topic has been closed to new replies.

About this Topic