WordPress.org

Ready to get started?Download WordPress

Forums

Constant Contact for WordPress
Your plug in is showing lists that I don't even have (10 posts)

  1. geniusventures
    Member
    Posted 4 years ago #

    I had them at one time. I don't anymore. So why are they showing up?

    My website is http://www.propertiescolorado.com
    It's currently up where you can see it.

    There is not a problem with my constant contact account. It's not a problem with my constant contact account. I verified this with them yesterday and I'm currently reverifying this as I'm typing. According to constant contact where I have been on the phone with yesterday and today those lists for The Back Fence The Back Fence 2 and The Back Fence 3 don't exist. I have gone in and deleted these lists and the contacts associated with them. In addition to this fact when I first installed this plugin I realized all of my list showed up. I went into constant contact and deleted some of those lists. Those lists are still showing up. When I go into edit details on the plugin to edit them. I don't see those lists anywhere on my radio buttons to either display or make them visible.

  2. Zack Katz
    Member
    Plugin Author

    Posted 4 years ago #

    This may be because of a new way the plugin stores lists. Try de-activating then re-activating the plugin and see if that fixes it.

    This will be fixed in the next release of the plugin; thanks for pointing it out.

  3. geniusventures
    Member
    Posted 4 years ago #

    I have installed and reinstalled the plug-in at least three times during this process. So clearly this does not work. What is even worse is that it is leaving stray bits of code on my site. e.g. You can check it out if you are inclined. http://www.propertiescolorado.com

    The plug in is currently completely uninstalled and deactivated. If you click on any of the search functions for real estate on my site. The plug in location for this is above the content left. When you click on anything there it takes you deeper into the site and it is still showing up. ????

    I'm trying to be nice especially since we are both denverites.

    When will the next version of the plug-in come out?

    I'm trying to keep this civil.

  4. Zack Katz
    Member
    Plugin Author

    Posted 4 years ago #

    Try this:

    1. In [your-wp-install]/wp-content/plugins/constant-contact-api/admin/options.php, find 'cc_widget_lists', near line 97.
    2. On a new line after that, add 'cc_widget_lists_array',
    3. Make sure your uninstall method in the plugin settings page is "remove"
    4. De-activate and re-activate the plugin.

    Let me know if that works.

  5. paulmp
    Member
    Posted 4 years ago #

    I'm having the same problem.. no matter what options I put in the check boxes, it shows *every* list that I have.. a fix for this ASAP would be really appreciated.

    - paul

  6. Joshua Knowles
    Member
    Posted 4 years ago #

    I am getting the same problem.

    @katzwebdesign i am not finding 'cc_widget_lists', anywhere near line 97.
    Can you give some of the surrounding code to help find it exactly?

    Any solutions to this? I also tried deactivating/reactivating and deleting/reinstalling plugin to no avail.

    I have completely different lists than it is showing. It shows an old list and that is it.

    Thanks for you help.

  7. ham.richards
    Member
    Posted 4 years ago #

    I am having the same problem. My CC lists have changed since I first installed the plugin. The settings page for the plugin shows the new names, but the widget displays the old ones. I have completely de-installed and re-installed the plugin, to no effect. Presumably something in a php database isn't getting updated.

    The phrase "cc_widget_lists" doesn't occur in the file constant-contact-api/admin/options.php anywhere near line 97.

    In line 30, we have

    register_setting($options_group, 'cc_widget_lists');

    The next occurrence is line 244:

    $selected_lists = get_option('cc_widget_lists');

    I plan to make a contribution to support this plugin, but not until this bug is fixed.

  8. Joshua Knowles
    Member
    Posted 4 years ago #

    Fix!

    1) Login to phpmyadmin
    2) Click on the database name your wordpress site is using
    3) Click on the search tab
    4) Type in the name of the list you want removed
    5) Select wp_options from the "Inside table(s):" list
    6) Click Go
    7) Click on browse from the results
    8) Delete the row with "cc_widget_lists_array" as the option_name

    Thats it!

  9. ham.richards
    Member
    Posted 4 years ago #

    Thanks for the fix--it worked for me.

    --Ham

  10. beyoyo2
    Member
    Posted 3 years ago #

    looks like this changed to _transient_gfcc_lists in the database.
    I just deleted out the lists that showed up there and now all my lists show up.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic