WordPress.org

Ready to get started?Download WordPress

Forums

Constant Contact for WordPress
[resolved] Opt-In Users Checkbox not working (10 posts)

  1. mstelten
    Member
    Posted 3 years ago #

    I have the Opt-In users by default box checked in the settings of your plugin. However, on my registration page, the box is not checked by default.

    I am running several other plugins on my registration page, including:
    Custom Fields, Register Plus

    Any ideas?

    Also, is there any way you know of to have the checkbox below the additional fields created by the Register Plus plugin ?

    Thanks!

  2. jamesbenson
    Member
    Plugin Author

    Posted 3 years ago #

    I can't answer your last question.
    What browser are you using?
    Can I see an example of the form which has the problem please?

  3. mstelten
    Member
    Posted 3 years ago #

    Here is my registration page:

    http://www.laarhovendesign.com/wp-login.php?action=register

    I have tried using safari, ie, and mozilla for both mac and PC

  4. jamesbenson
    Member
    Plugin Author

    Posted 3 years ago #

    I think one of the other plugins you have installed is breaking it somehow.

    Please try disabling any plugins that modify the register page and see if it works then.

  5. marie_a
    Member
    Posted 3 years ago #

    I am having the same problem, I have selected in settings for the opt-in to be checked by default, but it's not checked on the Register page. I tried disabling Theme My Login, but the checkbox is still unchecked on the Register page.

  6. evandavidpaul
    Member
    Posted 3 years ago #

    I have this problem as well. I even went so far as to edit the file, which i believe is named "functions.php" in the plugin. However I stupidly upgraded the plugin overwriting my change and now when I try to change it again it won't work. Shame on me, but please please fix this plugin.

  7. evandavidpaul
    Member
    Posted 3 years ago #

    For everyone having this problem open up the file users.php and edit line 373. Although this is only 1 of about 10 places in the code where an input box gets created, this is the one with the problem. You will blatantly see what is wrong once you finally find it.

    for anyone needing an immediate fix, change the line to: $checked = 'checked="checked"';

    To the plugin author, please for the love of god fix this before you update again or I will hunt you down instead of the bug.

  8. Zack Katz
    Member
    Plugin Author

    Posted 3 years ago #

    @evandavidpaul - Even though your "hunt you down" statement was a joke, I don't appreciate it. Not funny.

    Also, please note that I maintain this plugin at no cost, and that I have a job. I try to fix things as soon as possible, but it's not always on the top of my list. FYI: donations always helps get things fixed faster.

  9. Zack Katz
    Member
    Plugin Author

    Posted 3 years ago #

    This is fixed in version 2.1.2 of the plugin.

  10. evandavidpaul
    Member
    Posted 3 years ago #

    Thank you very much and I am sorry. I was venting my frustration on someone who has helped me out which is not right. Your plugin is very useful and a small bug causing me headaches is not your fault at all.

    Thank you again for the great plugin and I hope all your work goes smoothly.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic