WordPress.org

Ready to get started?Download WordPress

Forums

Constant Contact for WordPress
New Install Doesn't Take Off: fopen() Fails (5 posts)

  1. Michael
    Member
    Posted 2 years ago #

    Hi. I am using WordPress 3.3.2 and trying to get constant-contact-api working. As soon as I activate the plugin, I get long delays in the admin area and the rendered site. The delay seems to be exactly as long as it takes for fopen() to time out.

    After waiting for a few minutes, I finally get some errors that fopen() failed. The errors look like this:

    Warning: fopen(): Failed to enable crypto in /srv/www/example.com/wp-includes/class-http.php on line 877
    Warning: fopen(https://api.constantcontact.com/ws/customers/username/): failed to open stream: operation failed in /srv/www/example.com/wp-includes/class-http.php on line 877
    Warning: fopen(): SSL: Connection reset by peer in /srv/www/example.com/wp-includes/class-http.php on line 877

    Now I read something about fopen() issues in this plugin a while back, but I can't find where I read that, or if there was ever a solution.

    fopen() is allowed on the server. I tested fopen(), outside of WordPress, and was able to read a file from the internet. I was also able to use fopen() to read an SSL encrypted page from the internet. So I don't believe it is a server configuration. It may be a WordPress configuration.

    Does anyone have any insight?

    http://wordpress.org/extend/plugins/constant-contact-api/

  2. Zack Katz
    Member
    Plugin Author

    Posted 2 years ago #

    Is your site using SSL (https)?

  3. Michael
    Member
    Posted 2 years ago #

    No, the site is not using https at all. It is a rather plain WordPress site with a custom theme.

  4. Zack Katz
    Member
    Plugin Author

    Posted 2 years ago #

    It sounds like a server issue caused by:

    Warning: fopen(): Failed to enable crypto in /srv/www/example.com/wp-includes/class-http.php on line 877

    I don't know what that means, but you should call your host.

  5. Michael
    Member
    Posted 2 years ago #

    I think it is something about the Constant Contact site. I am able to use fopen to read from other SSL-encrypted sites, while the Constant Contact site always fails with a long timeout.

    But let's not worry about this any longer. It must be something peculiar to my setup if no one else is experiencing it. Thanks for the time and attention.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic