WordPress.org

Ready to get started?Download WordPress

Forums

Constant Contact for WordPress
Constantly Requiring New Password (14 posts)

  1. craigtommola
    Member
    Posted 2 years ago #

    The plugin seems to be connecting to Constant Contact so regularly that it's forcing new password requests. We keep resetting, but it's not making a difference. Consistently causing the user to reset their password at Constant Contact and in the plugin.

    Please advise ASAP.
    Thx
    CT

    http://wordpress.org/extend/plugins/constant-contact-api/

  2. katacomb
    Member
    Posted 2 years ago #

    I've come to the forums to investigate the same problem. Each morning I find the plug-in disabled due to a locked password on my Constant Contact account. I've spoken with tier-1 support at Constant Contact and they didn't have a fix. Please post any information you get on this issue. Thanks.

  3. pfaustino
    Member
    Posted 2 years ago #

    I'm having the same issues. I'm having to use Constant Contact plugin version 2.3.1 because our WordPress site is using version 2.9.2. There are no error messages with the installation.

    The following message appears everytime I try to get into the settings:
    "This plugin is not configured with a valid Constant Contact account.

    Please enter a valid username and password then press the Save Changes button before continuing."

    I've had to ask our Constant Contact admin to reset our password once already and I'm afraid it will get locked as everytime I try to change the settings for your Constant Contact plugin, it attempts to login with the password. I know the user name and password works because I've used it on the actual constantcontact.com website.

    Is this an issue with our verions of WordPress? I'm having a hard time convincing my boss to upgrade to 3.3.1 due to the possibility of the website breaking from currently installed plugins.

  4. elenaperez555
    Member
    Posted 1 year ago #

    I'm also having this issue. Does anyone have a fix?

  5. gWhat
    Member
    Posted 1 year ago #

    I am using WP 3.3.2 and CC API plugin 2.3.7. I have the same issue. I get this message: "This plugin is not configured with a valid Constant Contact account.Please enter a valid username and password then press the Save Changes button before continuing."
    My client has reset the password many times. It was fixed but is now broken again. CC says to contact the plugin developer.

    Does anyone have a solution?

  6. Zack Katz
    Member
    Plugin Author

    Posted 1 year ago #

    I'm working on finding out the problem. Sorry for this issue, everyone.

  7. gWhat
    Member
    Posted 1 year ago #

    I was using both your CC API plugin and the Gravity Forms CC plugin. After disabling the CC API and resetting the CC password, Gravity Forms CC plugin now works. At least for now.

  8. sachiak
    Member
    Posted 1 year ago #

    I am having the same problem. CC API Version 2.3.7 and WordPress 3.32.

  9. Zack Katz
    Member
    Plugin Author

    Posted 1 year ago #

    Please let me know if this is fixed in Version 2.3.8.

    As @gWhat mentioned, the Gravity Forms Constant Contact Add-on seems to not have this issue. You do need Gravity Forms ($39) to use the plugin, however.

  10. dstookey
    Member
    Posted 1 year ago #

    I'm dead in the water because of this problem! I can't get to my full Dashboard. Is there a solution? Where do I get step-by-step instructions to rectify this?

  11. Zack Katz
    Member
    Plugin Author

    Posted 1 year ago #

    @dstookey - Are you using 2.3.8?

  12. rebich01
    Member
    Posted 1 year ago #

    Hey Zack, have you figured out what the culprit was with this bug? I'm running CC-API (2.3.1) with CC-API Form Designer (alpha 2.3.9) and CC-Widget (2.0.3) on WordPress 3.2.1.

    I just upgraded CC-API to 2.3.9 and reset the password; it works for now. It seems that this warning disappears and reappears a day or two later for many people though, so I am still a little wary.

    Any updates on this issue?

  13. Zack Katz
    Member
    Plugin Author

    Posted 1 year ago #

    2.3.9 only checks the password once, making an incorrect password not trigger the password reset issue.

    It seems to have possibly fixed the issue…

  14. nef426
    Member
    Posted 1 year ago #

    Hi Zack,

    Still getting this issue -- (2.3.9) is immediately invalidating my constant contact password, and failing to authorize ("This plugin is not configured with a valid Constant Contact account.")

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic