WordPress.org

Ready to get started?Download WordPress

Forums

Connections Business Directory
[resolved] [Plugin: Connections] WP_DEBUG (6 posts)

  1. Jandal
    Member
    Posted 3 years ago #

    G'day Steven,

    As usual, many thanks for the great plugin.

    I'm currently experiencing the WSoD (White Screen of Death) on one of my WP installs and I'm trying to reduce the number of issues that could cause it. I am running a large number of plugins and yours happens to be one of them.

    I'm running my local WP install in

    define('WP_DEBUG', true);

    mode, this can be added to wp-config.php and I'm turning on 1 plugin at a time.

    I found a number of small issues with connections on the following pages, all easy fixes to remove the debug warnings.

    class.retrieve.php
    inc.shortcodes.php
    class.form.php
    class.output.php
    class.entry.php
    connections.php

    If you could please check connections with WP_DEBUG mode on to resolve any messages that come up for the next release, this would be amazing.

    Thank you for your time and creating a great plugin.
    Thanks,
    =-)

    http://wordpress.org/extend/plugins/connections/

  2. shazahm1
    Member
    Plugin Author

    Posted 3 years ago #

    This should now be resolved in version 0.7.1.5. Thanks!

  3. Jandal
    Member
    Posted 3 years ago #

    Awesome, thank you for the swift update.

    That has cleaned up the strays that were coming up in random places, there are still a few showing up when I'm outputting with a template.

    Undefined variable: linkindex in D:\websites\site.local\wp-content\plugins\connections\includes\class.form.php on line 174

    Undefined variable: out in D:\websites\site.local\wp-content\plugins\connections\includes\class.output.php on line 298

    Undefined index: name in D:\websites\site.local\wp-content\plugins\connections\includes\class.entry.php on line 886

    They are the only ones I can see left remaining.

    Amazing!
    =-)

  4. shazahm1
    Member
    Plugin Author

    Posted 3 years ago #

    I have to push another update later today, it seems I introduced a fatal bug under a specific usage scenario, so I'll make sure to address these as well.

  5. shazahm1
    Member
    Plugin Author

    Posted 3 years ago #

    I've fixed these but I'm quite certain there are more of the undefined variable warnings lurking about. Look for another update real soon.

    For others reading this, the warnings reported here will not negatively affect Connections functionality.

  6. Jandal
    Member
    Posted 3 years ago #

    Awesome, I will let you know if I find any more.

    I guess on that note this issue is resolved!

    Thanks,
    =-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic