WordPress.org

Ready to get started?Download WordPress

Forums

Connections Business Directory
[resolved] [Plugin: Connections] Google Maps (6 posts)

  1. slowbutsteady
    Member
    Posted 1 year ago #

    I have my directory shortcode placed within a jquery tab. Everything works great except the google map. Only a small part of the map appears. You can see an example by visiting this page example page and go to the "Eat" tab.

    Any assistance in resolving this issue would be greatly appreciated!
    Mike

    Connections Version 0.7.2.6

    http://wordpress.org/extend/plugins/connections/

  2. shazahm1
    Member
    Plugin Author

    Posted 1 year ago #

    What is the exact shortcode you're using? It seems the width option has been set to 70px.

  3. slowbutsteady
    Member
    Posted 1 year ago #

    Thanks for the quick reply Steven!
    I was using width='100%' in my shortcode. I thought I had read somewhere in the plugin docs that it would accept 100% as a width option..guess I was dreamin, can't seem to find that reference now. I went back through your width parameter info and noticed that the map defaults to the card width, that makes perfect sense! Thing is, I'm trying to get my desktop settings to play nice with my mobile site ones (Using WPTouch for mobile rendering). Setting the width to 100% makes the card itself resolve nicely in both formats, but obviously creates the map issue I'm experiencing.

    So it seems that leaves me with adjusting the card width down to a size that works well on the mobile view (400px), but then the desktop view is less than desirable. Any ideas that you could share would be most appreciated!

    As a side point, if I need to keep the 400px footprint, I'll need to remove the 'Phone' and 'Email' titles. I see how I can remove the text itself..but how can I stop the colon (:) from appearing. Can't seem to find where it's located in the script.

    Thanks for the help, like I mentioned before.. great plugin!
    Mike

  4. shazahm1
    Member
    Plugin Author

    Posted 1 year ago #

    There's another option, although not extensively tested...

    You can edit the functions.php, found here:
    ../wp-content/connections_templates/cmap

    Look for this block of code:

    // Set the entry card width and map iframe width defaults
    if ( empty($atts['width']) )
    {
    	$this->mapFrameWidth = 560;
    	$atts['width'] = 590;
    }
    else
    {
    	$this->mapFrameWidth = $atts['width'] - 30;
    }

    Change it to this:

    // Set the entry card width and map iframe width defaults
    if ( empty($atts['width']) )
    {
    	//$this->mapFrameWidth = 560;
    	//$atts['width'] = 590;
    }
    else
    {
    	$this->mapFrameWidth = $atts['width'] - 30;
    }

    Now, unless you specifically set a width, the applicable <div>'s will inherit width=100%.

    So, if you make this change, make sure to remove the width option from the shortcode.

    Oh, and Thanks!

    PS. You likely read the comment on my site where I said that didn't work in reply to someone setting the option the same way.

    PSS. The next cMap update will have the width default to 100% unless a width is manually set.

    PSSS. Hope this helps!

  5. slowbutsteady
    Member
    Posted 1 year ago #

    Thanks Steven for the reply!

    For the most part that does the trick! And it will be great to have a 100% option available in the next cmap update!

    In the desktop view, everything works perfectly.

    However, in the mobile view, most of the layout is working.., but when I try to select the Show Map option, the phone number in the next card down is what is selected. But if you go down to the last card on the page, it's Show Map page works correctly. If I take the width setting back to 400px, everything works fine on the mobile view.

    By the way, the Show Description (show bio) works correctly no matter what the setting.

    Not sure whether you've have a mobile option (I'm using a Samsung Stratosphere with Android OS). If you do, here's a page you can take a look at to see what's happening.

    A-Basin. It's in the Eat tab.

    The more I use this plugin, the more potential I see for it. You've done a great job on this plugin..keep up the good work! Hope you can think of something that might resolve this last issue.

    Mike

  6. shazahm1
    Member
    Plugin Author

    Posted 1 year ago #

    I took a look at the link on my Galaxy SII and all the links seemed to work fine for me.

    I also plan on removing the table layout from the template [I'm not longer going to support IE6/7] which should help.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.