WordPress.org

Ready to get started?Download WordPress

Forums

Connections Business Directory
[resolved] [Plugin: Connections] Can't add logo (7 posts)

  1. evgal92880
    Member
    Posted 3 years ago #

    I am trying to add a logo to an existing entry. It shows in the admin area, but not live on the site. I then created a new entry with the logo and same thing.

    Any ideas? Nothing's changed except for a WordPress Update.

    Gracias,
    Ally

    http://wordpress.org/extend/plugins/connections/

  2. nonenoknow
    Member
    Posted 3 years ago #

    It seems to only show images and not the Logo. Could not yet figure out why there is the Logo option!

    Cheers
    Christian

  3. shazahm1
    Member
    Plugin Author

    Posted 3 years ago #

    None of the templates provided show the logo.

  4. astralbaby
    Member
    Posted 3 years ago #

    Well, the logo itelf is making it into the /connections image directory, and it is also making it into the database as well.

    I just do not see any where in his source code where he defines a function for the logo ie. $entry->getCardImage().

    I see all kinds of support for it in the includes/class.options.php file.

    Also, the way the entry is in the DB is wierd.. I would write the query myself but I do not know how to the author has it setup.

    If you look in the connections table in the db and look at the options row.. you will see something like the below. keep in mind this is my content.. yours would be different..

    a:3:{s:5:"entry";a:1:{s:4:"type";s:10:"individual";}s:4:"logo";a:3:{s:6:"linked";b:1;s:7:"display";b:1;s:4:"name";s:18:"realtor_logo_2.jpg";}s:5:"image";a:3:{s:6:"linked";b:1;s:7:"display";b:1;s:4:"name";a:4:{s:9:"thumbnail";s:30:"NancyBridgewater_thumbnail.jpg";s:5:"entry";s:26:"NancyBridgewater_entry.jpg";s:7:"profile";s:28:"NancyBridgewater_profile.jpg";s:8:"original";s:29:"NancyBridgewater_original.jpg";}}}

    I cant wrap my head around that..

  5. astralbaby
    Member
    Posted 3 years ago #

    On the other hand.. if you would like to display what is in the notes area.. then do this..

    <?php echo $entry->getNotes() ?>

    in the template. In the Notes area, I just toggled the editor and put in a <img> tage to point to the logo I need put in.

    So there is my work-a-round, and I wont have to mess with his code base up forward compatibility for next version..

  6. shazahm1
    Member
    Plugin Author

    Posted 3 years ago #

    Here's the template tag that can be used.

    /**
    	 * Echo the logo if associated in a HTML hCard compliant string.
    	 *
    	 * Accepted option for the $atts property are:
    	 * 		tag == string -- HTML tag.
    	 * 		id == string -- The tag id.
    	 * 		class == string -- The tag class.
    	 * 		alt == string -- The tag alt text.
    	 * 		title == string -- The tag title text.
    	 * 		src == string -- The image source.
    	 * 		longdesc == string -- URL to document containing text for image long description.
    	 * 		style == associative array -- Customize an inline stlye tag. Array format key == attribute; value == value.
    	 * 		before == string -- HTML to output before the logo.
    	 *  	after == string -- HTML to output after the logo.
    	 * 		display == string -- Display place holder area or default image or logo. Permitted values are logo, place_holder, default, blank.
    	 * 		return == TRUE || FALSE -- Return string if set to TRUE instead of echo string.
    	 *
    	 * @param array $atts [optional]
    	 * @return string
    	 */
    	public function getLogoImage( $atts = NULL )
  7. astralbaby
    Member
    Posted 3 years ago #

    <?php echo $entry->getLogoImage() ?>

    YOU ARE THE MAN Steven! Thanks so much!!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic