WordPress.org

Ready to get started?Download WordPress

Forums

Easy FancyBox
[resolved] Plugin Conflict w/ LayerSliderWP (3 posts)

  1. Devin Walker
    Member
    Posted 11 months ago #

    I'm using LayerSliderWP and Easy Fancybox - there seems to be a conflict with the two plugins in the WP Admin Panel. LayerSliderWP includes a preview functionality in the slider builder UI. Easy Fancybox deregisters a dependent JS file (jquery easing) that breaks the LayerSliderWP preview functionality. I'm using the latest versions of both plugins. If I comment out lines 432 - 436 in easy-fancybox/easy-fancybox-class.php

    wp_deregister_script('easing');
    wp_deregister_script('jquery.easing');
    wp_deregister_script('jqueryeasing');
    wp_deregister_script('jquery_easing');
    wp_deregister_script('jquery-easing');

    ...it fixes the issue with LayerSliderWP. It seems that when you deregister jquery easing you should only do so on the frontend:

    if ( !is_admin() ) {
        wp_deregister_script( 'jquery.easing' );
    }

    I've tested this and it works fine from my initial testing. Please let me know if you need anymore info on this! Thanks for the great plugin.

    http://wordpress.org/extend/plugins/easy-fancybox/

  2. Devin Walker
    Member
    Posted 11 months ago #

    Any update or reply here? Easy Fancybox + LayerSlider is a combo I always use so adding compatibility would be very nice!

  3. RavanH
    Member
    Plugin Author

    Posted 10 months ago #

    Hi Devin, thanks for sharing! It'll be in the new release... :)

Reply

You must log in to post.

About this Plugin

About this Topic