WordPress.org

Ready to get started?Download WordPress

Forums

Configure SMTP
[resolved] SMTP sending error -- "Failed to connect to server" (4 posts)

  1. NearlyNubile
    Member
    Posted 2 years ago #

    I want to use Gmail to send email from our site.

    Settings are straightforward:

    SMTP server: smtp.gmail.com
    Port: 465
    Mail ID: admin@mysite.com
    Password: <correct password>

    But in the debug mode, I see this error when a contact form is submitted on our website:

    SMTP -> ERROR: Failed to connect to server: Unable to find the socket transport "ssl" - did you forget to enable it when you configured PHP? (5)

    How can I debug this? Maybe my firewall settings -- I use CSF/LFD on my WHM/Cpanel server. Quite a common setup?

    Much appreciate any help!

    http://wordpress.org/extend/plugins/configure-smtp/

  2. NearlyNubile
    Member
    Posted 2 years ago #

    Actually I fixed it by installing the SSL module (OpenSSL) via my WHM's "EasyApache". That enables the option automatically in PHP.INI, and the email is working. Hope this helps someone in the future.

    Thanks so much for a very simple, clear, straightforward plugin!

  3. inongimke
    Member
    Posted 2 years ago #

    Can you give me a little direction on what you did exactly? I really don't know where to begin, but I need to fix my faulty contact form.

    Where would I find the SSL module?

  4. anoopdhiman
    Member
    Posted 1 year ago #

    wp-mail-smtp plugin not working
    it gives the error

    SMTP -> ERROR: Failed to connect to server: Unable to find the socket transport "ssl" - did you forget to enable it when you configured PHP? (44727936)
    The following From address failed: anoopdhiman123@gmail.com

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic