WordPress.org

Ready to get started?Download WordPress

Forums

Conditional Widgets
Warning: in_array() [function.in-array]: Wrong datatype for second arg (2 posts)

  1. Richard Tape
    Member
    Posted 3 years ago #

    Hi there,

    This looks like an absolutely fantastic idea for a plugin. Genuinely brilliant, so thank you for it. I've just installed your latest version and come up against some PHP warnings, as follows:

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /path/to/my/plugins/conditional-widgets/cets_conditional_widgets.php on line 385

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /path/to/my/plugins/conditional-widgets/cets_conditional_widgets.php on line 385

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /path/to/my/plugins/conditional-widgets/cets_conditional_widgets.php on line 385

    Warning: in_array() [function.in-array]: Wrong datatype for second argument in /path/to/my/plugins/conditional-widgets/cets_conditional_widgets.php on line 385

    This only appears in the 'pages' section, not in the categories.

    Also, on top of this, it would be immense if this could work with custom post types, too. What are the odds of getting that into the next version?

    Again, thanks very much for this brilliant plugin.

    http://wordpress.org/extend/plugins/conditional-widgets/

  2. Jason Lemahieu (MadtownLems)
    Member
    Plugin Author

    Posted 3 years ago #

    Thanks for the details. I believe v1.0.1 should address these. Please update and let me know if you have any other problems.

    Custom post type support is a good idea - I'll put it on my ideas list!

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic