WordPress.org

Ready to get started?Download WordPress

Forums

Conditional CAPTCHA
[resolved] 403 forbidden error on captcha screen (3 posts)

  1. Norker
    Member
    Posted 3 years ago #

    Sorry if this is a newbish question as I am just learning WordPress. With the plugin activated and using re-captcha. I did a test with username viagra-123-test, email of test@test.com, website of viagra, and subject captcha test. The captcha screen comes up and looks like it should execept at the bottom of the screen it displays "You don't have permission to access wp-comments-post.php on this server." and then I tried typing something wrong in the captcha and got an internal server error. The same information works fine with plugin deactivated and akismet catches it without any error messages as above. Is this normal behavior? (I get same error with text captcha too.)

    I looked that error code in google search and got everything from editing .htaccess file to the fact that it is a google captcha issue. Do I need to even worry about this? Would legitimate commentors ever see that screen and get a server disconnect message? Or should I edit the .htaccess file and try that? I was leery of this option as I don't want to open up security loopholes.

    Thank you.

    http://wordpress.org/extend/plugins/wp-conditional-captcha/

  2. solarissmoke
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Norker,

    It looks like you probably have mod_security running on your PHP installation, and that is causing this. I suggest you try putting one of the following in your htaccess file:

    <Limit GET POST>
    order allow,deny
    allow from all
    </Limit>

    or

    SecFilterEngine Off

    I think the first option is better if it works (your provider may not allow either, in which case you need to talk to them), as the second one disables mod_security altogether. That said I think WordPress is pretty secure anyway, so you needn't worry too much about overriding it.

  3. Norker
    Member
    Posted 3 years ago #

    Hello solarisssmoke,

    I tried both but neither work so I will contact my provider to see what can be done. Thank you very much for your time.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic