WordPress.org

Ready to get started?Download WordPress

Forums

plugin compatability question (5 posts)

  1. isonychia
    Member
    Posted 1 year ago #

    I am learning the proper way to do all my updates.

    I am going through my plugins (updating all) and TRYING to verify if they will work with the latest version of WP before I update to WP 3.3.2

    The problem is on each plugins page it seems to have conflicting compatibility. (most likely I just don't understand how to decipher it) For instance on "Wp-Cycle" http://wordpress.org/extend/plugins/wp-cycle/

    On the right side it says:
    Requires: 3.0 or higher
    Compatible up to: 3.1.4

    BUT below that in the blue box it says:
    Compatability
    WordPress 3.3.2
    + Plugin 0.1.12
    = Not enough data

    So what does that mean?

    Does it mean it works up to 3.1.4 BUT WP does not know if it will work with 3.3.2?

    Thanks for the help,
    iso

  2. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    It means that the plugin has been officially tested by its developer with WP 3.1.4. However, it may still work with 3.3.2 - we just don't have enough data to say for sure.

  3. isonychia
    Member
    Posted 1 year ago #

    ok. Thanks Esmi.

    So that means if that plugin is VERY important to my sites functionality I am risking updating to the latest version of WP and having it not work?

    I did backup my entire site using BackWpup ( as far as what I read that plugin does that) but I don't want to have to resort to going back and reinstalling to the older version of the site. Because if I do that I know I will be missing something and the site will come down. Things like that never go smoothly.

    So I guess I am not sure what to do....

    iso

  4. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    So that means if that plugin is VERY important to my sites functionality I am risking updating to the latest version of WP and having it not work?

    Yes but then again, I'm using the odd plugin that is only officially tested with something like 2.9 and it's still working just fine. So there's really no hard & fast line we can give. Personally I tend to take other factors into account when choosing plugins:
    - how many people have downloaded it?
    - what kind of functionality does it provide?
    - have the hooks for this kind of thing changed since WP x.x?

    I also run a test server where all warnings and minor errors are logged and displayed in the screen, so I can test these plugins out in a verbose environment before I try using them.

    If all else fails, delete the plugin and look for another.

  5. isonychia
    Member
    Posted 1 year ago #

    Great info, thanks Esmi.

    iso

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.