WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: CommentLuv] The Link disappear [HELP] (8 posts)

  1. misheff
    Member
    Posted 4 years ago #

    This is my site - http://www.techwall.org/
    I insert <?php cl_display_badge(); ?> into my comments.php template but when i do that link to user last blog post its not showing! Please visit my site, try comment to see what i am talking about and give me a solution. Thanks!

  2. freakenstein
    Member
    Posted 4 years ago #

    Same problem here.
    (WP2.8.4)
    When using the template function it doesn't work

    Use template insert to show badge and checkbox? ( <?php cl_display_badge(); ?> )

    When using the standard behavior is does work.

  3. teamplaylotto
    Member
    Posted 4 years ago #

    check to make sure that you have selected the checkbox for using the template insert and make sure that your comments.php file has do_action('comment_form', $post->ID);
    before the closing /form tag (wrap it in php tags)

    the do action command lets commentluv (and other plugins) know that the comment form is being output. that's where commentluv adds some hidden fields to the form for holding the luvlink data.

    if you don't have the do action there, no fields get added and commentluv doesn't see any values so it exits.

  4. freakenstein
    Member
    Posted 4 years ago #

    My theme has in comments.php

    <!-- comment input -->
            <div class="row">
            	<textarea name="comment" id="comment" tabindex="4" rows="8" cols="50"></textarea>
            	<?php if (function_exists('highslide_emoticons')) : ?><div id="emoticon"><?php highslide_emoticons(); ?></div><?php endif; ?>
            	<?php if (function_exists('comment_id_fields')) : comment_id_fields(); endif; do_action('comment_form', $post->ID); ?>
            </div>
            <!-- /comment input -->

    Which is placed somewhere between <form></form>
    :S

  5. jasicom
    Member
    Posted 4 years ago #

    <input name="submit" type="submit" id="submit" tabindex="5" value="Send Comment" class="replybutton" />
    <input type="hidden" name="comment_post_ID" value="<?php echo $id; ?>" />

    <?php do_action('comment_form', $post->ID); ?>

    <?php cl_display_badge(); ?>

    </fieldset>
    </form>

    Is this the thing right way? i cant see any new items after installinf the commentluv.. pls help me Mr teamplaylotto

  6. jasicom
    Member
    Posted 4 years ago #

    where we place <?php cl_display_badge(); ?> tag?

  7. intenseblog
    Member
    Posted 3 years ago #

    I think the problem are resolved :), you can check about Optimize the CommentLuv wordpress plugin

  8. teamplaylotto
    Member
    Posted 3 years ago #

    sorry for not replying sooner, I always assume someone will come to comluv.com as is mentioned in the plugin page if they want support.

    you can put <?php cl_display_badge(); ?> anywhere on your page if you have comments enabled and the <?php do_action('comment_form', $post->ID); ?> inside the <form> tag and it will display the pull down box in that position.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags