WordPress.org

Ready to get started?Download WordPress

Forums

Comment Guestbook
[resolved] Not showing anything (20 posts)

  1. flacens
    Member
    Posted 1 year ago #

    i've installed the plugin, activated it, and added the shortcode "[comment-guestbook]" to a new private page i've created and when i go to the page, no guest book or form shows up on the page...am i missing something?

    thanks in advance

    http://wordpress.org/extend/plugins/comment-guestbook/

  2. mibuthu
    Member
    Plugin Author

    Posted 1 year ago #

    Did you enable "Allow comments" for that page?
    This is required to show the the form and also the comments.

  3. flacens
    Member
    Posted 1 year ago #

    Im sorry but I can't seem to find the "allow comments" option anywhere. Where would that be??

  4. mibuthu
    Member
    Plugin Author

    Posted 1 year ago #

    Goto the admin page, edit your guestbook site:
    There should be an column called "Discussion" with the option "Allow comments." If you can't see this column, probable it is disabled in the "Screen Options". You can find them in the upper right corner.

  5. flacens
    Member
    Posted 1 year ago #

    Ok thank you, I got the "allow comments" to show up and enabled it, but I left a comment and now that won't show on the page. I already approved the comment

  6. mibuthu
    Member
    Plugin Author

    Posted 1 year ago #

    Can you please give me some more infos to help me finding the problem:
    - Do you have this problem for every comment you made?
    - Did you change any setting of comment-guestbook plugin?
    - Can you solve the problem if you change some of the settings for the comment list output or does this have no influence?
    - Can you see the missing comments when you temporarily remove the shortcode from the page?
    - Which wordpress version do you use?
    - Which php-Version do you use?

    Please answer these questions to help me finding the problem.
    Thanks in advance.

  7. tunixtunix
    Member
    Posted 1 year ago #

    Hi there,
    I have the same problem. I see the comment form and can leave a comment. The comment appears in the backend and I can approve it. But they won't show up on the guestbook page.

    Your questions:
    - Do you have this problem for every comment you made?
    No. Other comments on articles work fine.

    - Did you change any setting of comment-guestbook plugin?
    No. everything is default. I just re-installed it and left everything as it was.

    - Can you solve the problem if you change some of the settings for the comment list output or does this have no influence?
    I do not see any differences. I switched "Adjust the comment list output" on and off and played around with the list order. I do not see any changes.

    - Can you see the missing comments when you temporarily remove the shortcode from the page?
    No. The page is empty then.

    - Which wordpress version do you use?
    3.4.2

    - Which php-Version do you use?
    5.2.13

    I would appreciate any help - thanks

  8. mibuthu
    Member
    Plugin Author

    Posted 1 year ago #

    Hi tunixtunix,
    thanks for your help and providing the answers to my questions. The problem is that I still didn't found out what's going wrong. I saw that you are using php 5.2 which I didn't tested til now. So I've prepared an installation with that version and tested the plugin again. But also with this installation the plugin works as expected.

    I've created a detailed step-by-step test manual now with a description of the proper result:

    1.Create a new page and check if comments are working:
    a. goto to wp-admin -> Pages
    b. create a new empty page (Add New) and enter a page name
    c. enable "Allow comments" in the Discussion box
    d. Publish the guestbook page
    e. switch the frontend and goto the new page
    f. create a new comment
    -> The page should contain the title of your site at the top, your new comment and the comment form at the bottom.

    2.Add the comment guestbook shortcode and check the comments again:
    a. switch to wp-admin
    b. install and activate the comment-guestbook plugin
    c. edit the page you've created before
    d. add the [comment-guestbook] shortcode in your page
    e. for testing add also some text before and after the shortcode
    f. Update the page
    g. switch to the frontend and goto the guestbook page
    -> The page should contain the following parts from top to bottom: the title, the text before the shortcode, the comment form, the text after the shortcode, your first comment, another comment form at the bottom.

    3.Add a new comment:
    a. goto the guestbook page on the frontend
    b. add an additional comment in one of the two comment forms
    c. post the new comment
    -> After that you should have the same parts like above, but you should see booth comments now.

    4.Change the comment list output in the options:
    a. goto wp-admin -> Comments -> Guestbook -> Comment-list settings
    b. enable "Adjust the comment list output"
    c. disable "Add an additional comment form below the comments"
    d. add another comment on the comment guestbook page in the frontend
    -> You should have the same parts like above, exept the comment form at the end should be missing. You should also see all three comments now.

    5.Disable the comment-guestbook plugin:
    a. goto wp-admin -> Plugins -> Installed Plugins
    b. click on "Deactivate" link of Comment Guestbook
    c. switch back to the frontend to your guestbook page
    -> Instead of the first comment form you should see [comment-guestbook] now. The comment form at the bottom of the page should be back again.

    If you're still interested in my plugin can you please go through each step and send me your feedback. Please tell me which parts are working and where do you have differences. Please discribe the differences in detail.

    I want to thank you in advance for your help.

  9. AJKock
    Member
    Posted 1 year ago #

    Ok, I am stuck on Point 1. I can't add comments to a Page even after allowing it on Page Editing.

  10. AJKock
    Member
    Posted 1 year ago #

    Ok, problem solved. I understand why some people probably didn't come back to you, because it is embarrassing. :)

    I am using Trim from Elegant Themes. They have confusing wording in their theme admin section, where they talk about "Post Pages", instead of just Posts. My theme blocked comments on pages even though I had it switched on via the Page Edit options. I have now switched it on under "Single Page Layout" options and it is working.

    Sorry for making you stress unnecessarily. The plugin is now working fine perfectly except for the duplicate "Comment" box.

  11. mibuthu
    Member
    Plugin Author

    Posted 1 year ago #

    Hi AJKock,
    thanks for your reply.
    I have added some options to set the comment box to different positions in the new version 0.2.2.

  12. antoine69
    Member
    Posted 1 year ago #

    Hi,
    I hab the same problem (comments not showing after posting).
    I followed your guidelines above and reached the point 5 without problem with the twentytwelev theme and the 0.2.2 plugin version.
    My problem is as soon as I switch to my theme, comments never show on my page.
    One thing I wanted to say, in the comment-list settings tab, there's an option to set the comment callback function. When I switched to my theme, I also changed the name of this function by mytheme_comment while adding the twentytwelve_comment function (in the function.php) to my theme functions.php and changing the names inside. But the result is the comment don't show up !
    So I'm stucked.
    How you got an idea ?
    Thanks

  13. mibuthu
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry for the late reply.
    I have now installed the Trim theme from Elegant Themes to have a look what's going wrong. What I found out is that all the comment-guestbook options are working, the only problem is that the theme allows disabling the comment section. If this section is disabled the comments are not shown and also eventually enabled comment-forms in this sections are not visible.
    So please have a look if your theme gives an option for that. Try the guestbook page with a standard theme like twentyeleven to check if your theme is the problem.
    Perhaps I will add another option in one of the next versions to add the comments list in the page area, this would allow to overwrite this theme issue.

  14. engeldeluxe
    Member
    Posted 1 year ago #

    I have the same problem: the theme. What could I do to sho the comments? Can I read how where I need to change the theme somewhere?

  15. mibuthu
    Member
    Plugin Author

    Posted 1 year ago #

    It depends on the theme. Look into the settings of your theme if you can find an option to view the comment list.
    I will probably add the possibility to include the comment list in the page content in one of the next versions. This would help to add the comment list for these special themes.

  16. engeldeluxe
    Member
    Posted 1 year ago #

    Thank you for your answer. But there is no option in the settings.
    I tried to search what I have to change in the theme-code. But I didn't find anything about. Do you have a tip on how I can pass the time until the next version of your plugins? Or where I can read up on how it should be written into the code of the theme?

  17. jessicagallagher2013
    Member
    Posted 1 year ago #

    I believe I'm having the same problem, I'm using this pirate theme and I'm very sure it's the cause of the comment widget not working, is there any way to get around it anf force it to work or do I have to find a new theme?

    the url for my site is http://www.blacksparrowpirates.com/home/

  18. rvmrotterdam
    Member
    Posted 1 year ago #

    I see the comment form and can leave a comment. The comment appears in the backend and I can approve it. But don't show up on the guestbook page. Will you please have a look at this snapshot demonstrating the problem and showing you the settings of the plugin : comment-guestbook

  19. mibuthu
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for the video, this is a great help.
    It looks like you have no comment list at all on your guestbook page.

    There are 2 more things to check:

    1. Please have a look if the comments are enabled on the guestbook page.
    To enable it edit the guestbook page. There you can find a box called "Discussion", if you cannot see it you probably have to enable it in the screen options in the top right corner. In the discussion box please have a look if "Allow comments" is enabled.
    This option should be overwritten by the guestbook option "Allow comments on the guestbook page" but perhaps something isn't working correct.

    2. What theme are you using?
    Does your theme have a special options page where you can change the discussion settings? If this is the case the theme option overwrites the discussion option of the page.

    I think the theme is the problem, you can also read this in all the other posts in this thread.

  20. rvmrotterdam
    Member
    Posted 1 year ago #

    Thank you very much.
    The theme option page showed a checkbox to allow comments. This box was not checked. I changed the setting and now everything works perfectly. (5 stars)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.