WordPress.org

Ready to get started?Download WordPress

Forums

Codestyling Localization
[resolved] WP_DEBUG errors triggering scriptguard (2 posts)

  1. Earthman Web & Media
    Member
    Posted 2 years ago #

    Hi, love your plugin!

    When I enable WP_DEBUG though, the FATAL error thrown, as follows, triggers the Scripting Guard you have installed: :

    Malfunction at current Theme detected!
    Name: Fatal error: Cannot use object of type stdClass as array in /opt/bitnami/apps/wordpress/htdocs/wp-content/plugins/codestyling-localization/codestyling-localization.php on line 2342

    See screenshot at: http://screencast.com/t/pRj6dqtm1

    Please advise.

    Cheers!
    Terran

    http://wordpress.org/extend/plugins/codestyling-localization/

  2. codestyling
    Member
    Plugin Author

    Posted 2 years ago #

    This is a bug within the message generation only, the function of plugin and also Guard works as expected, because the message will be created using an ajax call.
    I've scheduled an update very soon, if you want it get working sooner, than you can replace for now following lines (2342 and 2343):

    <?php _e('Name:',CSP_PO_TEXTDOMAIN);?> <strong><?php echo $ct['Name']; ?></strong> |
    <?php _e('Author:',CSP_PO_TEXTDOMAIN);?> <strong><?php echo $ct['Author']; ?></strong><br/>

    with this lines:

    <?php _e('Name:',CSP_PO_TEXTDOMAIN);?> <strong><?php echo $ct->name; ?></strong> |
    <?php _e('Author:',CSP_PO_TEXTDOMAIN);?> <strong><?php echo $ct->author; ?></strong><br/>

    This fix will be contained at version 1.99.22 comming soon.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic