WordPress.org

Ready to get started?Download WordPress

Forums

Codestyling Localization
[resolved] WP forum server - localization not showing at all (10 posts)

  1. yoolee
    Member
    Posted 1 year ago #

    Hi, I have translated all expressions of WP Forum server, generated the .mo file but nothing is happening. Checking in the option tab of WP Forum the default languages can be seen only and in the wp forum folder/languages folder on the server there is no .mo nor .po files for my Hungarian translation. What am I missing?

    http://wordpress.org/extend/plugins/codestyling-localization/

  2. codestyling
    Member
    Plugin Author

    Posted 1 year ago #

    What type of forum you are using? Stand alone, per BuddyPress or anything else? I need more specific information to prepare a local test environment.

  3. yoolee
    Member
    Posted 1 year ago #

    Thanks, I already posted onto your website about this, just let me know where you answer and I don't do duplicate posts about it. THanks again!

    I am using WP Forum Server 1.7.4. I added my language (Hungarian) translated the expressions, clicked on generate .mo file and then went to check if the Hungarian texts appear - but they do not. Then did some backcheck, translated some other plugin - WP Favicon - to see if that is working and there are no problems there, Hungarian texts are showing.
    I get this warning with WP Forum Server:
    Author is using load_textdomain instead of load_plugin_textdomain function. This may break behavior of WordPress, because some filters and actions won’t be executed anymore. Please contact the Author about that.

    Checked the /web/wp-content/plugins/forum-server/languages folder and there are no Hungarian files there. Also checked the options panel of WP Forum Server and only the 3 default languages are shown.

  4. codestyling
    Member
    Plugin Author

    Posted 1 year ago #

    This plugin load the textdomains the none standard way and is not compatible as expected:

    if ($this->current_lang && $this->current_lang != $this->options['forum_lang']) {
    	$plugin_dir = basename(dirname(__FILE__));
    	$lang_dir = ABSPATH.'wp-content/plugins/forum-server/languages/';
    
    	if (file_exists($lang_dir.'vasthtml_'.$this->current_lang.'.mo')) {
    		load_textdomain("vasthtml", $lang_dir.'vasthtml_'.$this->current_lang.'.mo');
    		// global wordpress translate method with wp-config.php WPLANG
    		//load_textdomain("vasthtml", $lang_dir.'vasthtml_'.$this->current_lang);
    	} else {
    		die('Language (.mo) file doesn\'t exist or accessible');
    	}
    }

    Normally it should never call die if the translation file is missing, nor it should explicitly load it with gerneric version of load method.

    The prefered way loading the textdomain for this plugin should be:

    load_plugin_textdomain("vasthtml", PLUGINDIR.'/forum-server/languages', 'forum-server/languages');

    This is strongly bound the the blogs language. If the Forum has their own lang management, there are quiet better ways to do this.

    My plugin will generate a translation file (and did it at my local install) like: "vasthtml-hu_HU.po" and is able to translate and generate the appropriated *.mo file.

    But the forum plugin tries to load "vasthtml_hu_HU.mo" which doesn't exist. The author of this forum plugin exchanged (mistakenly ?) the minus char with the underscore char. This leads to not loading translations did by my translation plugin.

    Please inform the author of forum server to correct the issues.

  5. yoolee
    Member
    Posted 1 year ago #

    So is this a problem for everyone using these two plugins? I found this information on ForumPress' website:
    http://forumpress.org/localization

    They don't seem to be aware of the -/_ problem.

  6. codestyling
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, indeed it's a problem for all user of the forum plugin. There needs to be a solid solution at the forum server plugin to meet the correct language handling.

  7. yoolee
    Member
    Posted 1 year ago #

    Ok, now I have yet another interesting issue. I translated all expressions of WP Forum Server plugin yesterday and luckily saved both .mo and .po files to my pc and today I don't see the Hungarian language in the Localization plugin next to the WP Forum Server in Dashboard/Tools! It has disappeared completely!

    I tried uploading the .mo and .po files to the language folder on the server with the _ instead of the - in the file names but there is still no translation on my site.

    Please let me know what to do, this is the third time I have translated the whole plugin :(

    Thanks again

  8. codestyling
    Member
    Plugin Author

    Posted 1 year ago #

    Files created with the plugin doesn't do disappear. If you create the translation base (*.po) and it pops up inside the list of available translations, than it will be found always there. If afetr creation the file doesn't show up at list, the server configuration is somehow not standard.

    if it worked yesterday but missing today, do you have any cleanup or monitoring tool removing any files on some cirumstances?
    Do you have other plugins installed dealing with languages (like multi language plugins, backup or routing things)?

    Its difficult to say, what went wrong without the physical access to the affected machine for investigation. Locally I can't reproduce the issue. If it would be an option to permit access to the affected machine, please let me know by mail (can be found at my imprint page).

  9. yoolee
    Member
    Posted 1 year ago #

    The actual translation was never visible on my site. I have already turned off plugins that could mess with the translation (qTranslate) but still there is nothing showing of what I have translated.

    This is what disappeared since yesterday: https://www.dropbox.com/s/d0objm17xy1wp1s/2012-05-22-Localization.png as you can see, there is nothing there although I have the files that were generated because I saved them to my pc. Could this be a problem, do I have to upload them here somehow?

    I have the vasthtml_hu_Hu.mo and .po files in the appropriate folder on the server, don't know what elso I could do.

  10. yoolee
    Member
    Posted 1 year ago #

    This is really annoying that you on one hand are more than helpful but forumpress is not answering any of my questions no matter where I post them. More kudos to you for it!
    This is clearly a CodeStyling vs. ForumPress problem because I don't have these issues with other translated plugins.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic