WordPress.org

Ready to get started?Download WordPress

Forums

Codestyling Localization
[resolved] CodeStyling Localization - Access Error (15 posts)

  1. ecabral
    Member
    Posted 2 years ago #

    I keep getting this error whenever I try to rescan my WP language files:

    CodeStyling Localization - Access Error

    I uploaded the .po and .mo files to the root folder of my theme per http://goo.gl/Fjm9k, but it didn't work.

    Rescanning/editing the language files for themes and plugins works perfectly.

    Any suggestions on what to do? I've spent hours already searching for a solution and am getting nowhere...

    Thanks!

    http://wordpress.org/extend/plugins/codestyling-localization/

  2. codestyling
    Member
    Plugin Author

    Posted 2 years ago #

    Seems that your server uses a different user for FTP and PHP execution. This may affect files uploaded by FTP and modified by PHP. Downloaded plugins and themes within WordPress by PHP should be translatable.
    This problem will be solved in future versions.

  3. ecabral
    Member
    Posted 2 years ago #

    Thanks for the update!

    I just upgraded to v. 1.99.20, but the scanning problem persists. I assume this wasn't meant to be fixed in this release, right?

    Thanks!

  4. codestyling
    Member
    Plugin Author

    Posted 2 years ago #

    Question #1: Do you need FTP credential for automatic updates of Plugins/Themes or WordPress itself?

    Question #2: Is your WordPress installation able to automtic update in any case?

  5. ecabral
    Member
    Posted 2 years ago #

    Hi codestyling,

    Thanks for the reply!

    #1: I'm not using FTP. I installed WordPress on Blueshost, so access my files via CPANEL. I update plugins/themes/WP via the WordPress dashboard. Updates are not automatic.

    #2: Not sure it's able to do that on the server... So far, I've always got warnings to update and the update didn't happen until I clicked the update button.

    Let me know if you need more info.

    Cheers!

  6. codestyling
    Member
    Plugin Author

    Posted 2 years ago #

    If you have the file po or mo symbol shown in red color instead of green, it has the wrong permission to be modified. Please click at the red symbol to change the permission.

    If this still doesn't work, try the 1.99.21 which detects your capabilities at your file system more qualified.

  7. ecabral
    Member
    Posted 2 years ago #

    Hi!

    The po and mo symbols are green, not red.

    Just upgraded to v. 1.99.21, tried to rescan the WP files again and I still get the same access error. How can I change permissions?

    Thanks!

  8. codestyling
    Member
    Plugin Author

    Posted 2 years ago #

    If version 1.99.22 doesn't solve your problem, please send me an email about your install. I would need at least access to your backend for investigation of this particular problem. I can't reproduce it locally.

  9. ecabral
    Member
    Posted 2 years ago #

    Thanks! Just sent you an email.

  10. codestyling
    Member
    Plugin Author

    Posted 2 years ago #

    The rescan process works, if you enable the low memory mode checkbox at the upper left corner of my plugins page.
    Your 84MB with this ammount of installed plugins will not be sufficiant to re-scan WordPress itself without the low memory mode.

  11. ecabral
    Member
    Posted 2 years ago #

    Indeed it does! Thank you so much for debugging this! You've been absolutely awesome!

    PS: Just made a small donation as a sign of appreciation for the wonderful tool and support!

  12. jorijnsmit
    Member
    Posted 1 year ago #

    Thanks a lot this worked for me too.

  13. Luis Torres
    Member
    Posted 1 year ago #

    Hi all, my desktop is empty. It seems that when I upload the po and mo files to translate my theme there is a conflict that will not let me use any of the functions, however, the site works perfectly. I'm using the latest version. I would appreciate any help infinitely.

  14. codestyling
    Member
    Plugin Author

    Posted 1 year ago #

    Could you please describe the problem more in detail?
    What meens "empty desktop"?
    What plugins and theme is running beside my plugin?

  15. pricklepantz
    Member
    Posted 1 year ago #

    Sorry to jump in rather than creating new topic.
    If the enable low memory mode is enabled but still asks for it, what do i do with that?
    I just updated it to latest version.
    Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic