WordPress.org

Ready to get started?Download WordPress

Forums

Co-Authors Plus
[resolved] Co-authors plus not working in Vigilance (4 posts)

  1. ecila
    Member
    Posted 2 years ago #

    I just installed co-authors plus 2.5.3 and all seemed tickety boo. New edit box appears at the bottom and authors are auto-completed.
    All looks good in the dashboard - i.e. dual authors appear, but in preview or publish mode, just the single author appears.

    I am using a simple child derivation of Vigilance, with no custom post.php or page.php. I saw a reference to known issues with the thematic themes that pointed to co-authors not returning a value.

    I also tried testing it on my local multi-site instal to ensure that it is not something in my child theme. Same issue applies with Vigilance itself.

    Any ideas ?

    Many thanks in advance.
    Alice

    http://wordpress.org/extend/plugins/co-authors-plus/

  2. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 2 years ago #

    All looks good in the dashboard - i.e. dual authors appear, but in preview or publish mode, just the single author appears.

    You'll want to update your theme's templates to support Co-Authors Plus template tags. This should be as simple as copy and pasting, but you'll need to track down the proper place to do it.

    I'd recommend posting your question to your theme's support forums if you haven't figured it out already.

  3. ecila
    Member
    Posted 2 years ago #

    Thanks for your reply Daniel.
    I have it working locally, by substituting the get_author() with get_co-author_posts() as per the lovely clear notes in co-author plus pages. But for some reason beyond me, when I upload the new index.php to my child theme live it doesn't work (the correct index.php is being read).

  4. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 2 years ago #

    But for some reason beyond me, when I upload the new index.php to my child theme live it doesn't work (the correct index.php is being read).

    When you mention that the new index.php "doesn't work", what are you seeing instead?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic