WordPress.org

Ready to get started?Download WordPress

Forums

Co-Authors Plus
[resolved] admin posts count are wrong (16 posts)

  1. Omid Korat
    Member
    Posted 2 years ago #

    When I enable Co-Authors Plus 2.6.1, all admins posts count set to 1. But as I disable the plugin, it shows real posts count.
    I really need this plugin. Please provide a solution.

    http://wordpress.org/extend/plugins/co-authors-plus/

  2. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 2 years ago #

    Can you try going to a post where the author is set, hitting update, and seeing if the post count is corrected?

  3. Omid Korat
    Member
    Posted 2 years ago #

    It doesn't change post count.

    I find one other user that his post count is wrong too. so it's not just for admins.

  4. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 2 years ago #

    Does this problem persist when all other plugins are deactivated? Can you share a screenshot of your all users and all posts pages here please?

  5. Omid Korat
    Member
    Posted 2 years ago #

    I deactivated all other plugins, but it doesn't change.

    wrong number in users list:
    screenshot

    true number when I click my name in list:
    screenshot

    wrong number in site:
    screenshot

  6. Shmi1051
    Member
    Posted 1 year ago #

    Hi Omid,

    "Today" becomes "yesterday" too early. What's to be done ?
    Be possible to add a sorting on the dates in the setting ?

    Thanks

  7. Shmi1051
    Member
    Posted 1 year ago #

    I added date_default_timezone_set('America/Montreal') in timeline.php and that works.

  8. bjo
    Member
    Posted 1 year ago #

    This issue also exists with 2.6.4.

  9. Shmi1051
    Member
    Posted 1 year ago #

    Sorry. My question is not for this plugin. It's for Timeline Calendar
    http://wordpress.org/support/plugin/timeline-calendar

  10. Oldenburger Lokalteil
    Member
    Posted 1 year ago #

    Got the same Problem with the count.

    It seems to me that the number of articles for each user had been set to zero for all administrators - except "admin", which is kind of funny - after installung the plugin. Afterwards it seems to count correctly every time the user is picked as an author.
    For example: The Plugin said "O" for a special user but should have said something about 170. After a few days and some new posts it now says 12, which is correct for this period.

    The problem doesn't seem to occur with non-admins.

  11. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 1 year ago #

    The author posts count actually becomes the term count for the author term, because the plugin stores co-author term.

    It's odd that it's not a problem for non-admins though. The count should be updated for each author on a post, every time you update a post.

    Any more debugging you've done, or details to share?

  12. Oldenburger Lokalteil
    Member
    Posted 1 year ago #

    I know it would be helpful to disable all other plugins, but at the moment it's far too much work...

    I found that if I click at the author's name, all of his posts are correctly listed, despite the wrong number in the list of users/authors.

    So I need to edit and update all former posts one by one to get the correct number? All ~150? *sigh*

  13. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 1 year ago #

    I'll see if I can prepare a script for you to run, although it will be a little bit.

  14. Oldenburger Lokalteil
    Member
    Posted 1 year ago #

    Oh, that would be nice (but no need to hurry). ;)

  15. christianbolstad
    Member
    Posted 1 year ago #

    Hi, I got the same problem with the count number beeing incorrect - both for admins and other user roles. At first we noticed that an update (re-save of a page) would update the number, but after a manual update of all pages, the count is still incorrect for some users.

  16. Daniel Bachhuber
    Hand Built
    Plugin Author

    Posted 1 year ago #

    I've made some recent changes and this should be fixed in an upcoming version.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic