WordPress.org

Ready to get started?Download WordPress

Forums

CMS Tree Page View
Critical Bug: Plugin breaks editing of already saved/published posts/pa (18 posts)

  1. gaplauche
    Member
    Posted 4 years ago #

    I really like this plugin, but I had to deactivate it.

    I recently noticed that when I tried to edit an already published post/page, or even an unpublished post/page that had been saved or auto-saved as a draft (then you exit the editor and later come back to edit again), that many of the text fields would not accept any keyboard entry. The affected fields include, but may not be limited to, the title, the url slug, the text area when set to the html tab (but not when set to the visual tab), the Simple Tags plugin field, the scheduling/published-on date/time fields.

    For some reason this problem does not affect freshly started new pages or posts. But as I said, once a post or page has been published, or saved, then when you go back to edit it the problem arises.

    So I went through my plugins, deactivating them one by one until the problem went away. It was the deactivation of this plugin that caused the problem to disappear.

    I can't use this plugin until this bug is fixed.

    I'm running WordPress 3.0 with the Thesis 1.7 theme.

    http://wordpress.org/extend/plugins/cms-tree-page-view/

  2. Pär Thernström
    Member
    Plugin Author

    Posted 4 years ago #

    Thank you very much for the bug report. I can however not reproduce this bug myself. If anyone else out there is having the problem, please let me know!

    Can you possible give me some more info about your setup, like what browser and OS you are using, and also if you had any other plugins running (I know you deactivated some plugins, but did you have any left enabled?).

  3. gaplauche
    Member
    Posted 4 years ago #

    I ran into the same problem on Windows 7 and Ubuntu 10.04. I mainly use Google's Chrome browser, but I think I ran into the same problem with Firefox as well.

    I have a lot of plugins installed. I had disabled a bunch, but still have quite a few others activated when I discovered that deactivating this plugin solved the problem. I'll have to try get back to you on which I had deactivated and which activated. I don't remember precisely.

  4. Scott Lewis
    Member
    Posted 4 years ago #

    I am having the same exact problem. I am using Vista, Firefox (though I had the same issue on IE and a Mac), and WordPress 3.0. I have a lot of plugins installed. You can see which plugins I am using at http://www.focusedbusinessaction.com/my-plugins/.

  5. Pär Thernström
    Member
    Plugin Author

    Posted 4 years ago #

    @slewwho thanks for the plugin-list. Gonna install them one after one and see if I end up having the same problem.

  6. Scott Lewis
    Member
    Posted 4 years ago #

    I just deactivated all of my plugins except for CMS Page Tree View and it still shows the same symptoms. When the plugin is enabled, I am unable to edit in HTML mode, but have no problem in Visual mode. Once I deactivate the plugin, the problem goes away.

    My theory is that the problem started with WP 3.0, but I don't know for sure. It's possible I just didn't notice it before since I haven't had the plugin for very long.

  7. Pär Thernström
    Member
    Plugin Author

    Posted 4 years ago #

    Can you give me some more details; can you for example focus the text fields, but then nothing happens when you press chars on your keyboard?
    Does none of the fields in the post edit screen work, or is it just some of them that stops working?

    I just can't figure out what's causing this.. :/

  8. Scott Lewis
    Member
    Posted 4 years ago #

    Yes, when the plugin is activated you can focus the text fields, but then nothing happens when you press chars on the keyboard. This is true for all fields on the page - edit, title, tags, etc. The only one that seems to work is the Visual field. When I deactivate the plugin, everything works again.

  9. Pär Thernström
    Member
    Plugin Author

    Posted 4 years ago #

    Hi again everyone. Just wanna let you know that I know what's causing this problem now. I'm not sure that I can fix it, but I'll will of course try to fix it. Stay tuned, and thank you for your patience.

  10. tradiart
    Member
    Posted 3 years ago #

    http://wordpress.org/support/topic/plugin-cms-tree-page-view-can-not-edit-any-pages-or-posts-when-this-is-installed

    Another post asking for the same issue.

    Seems that even deactivating all plugins, this issue remains.

    Using a Thematic child theme. Thank you Pär.

  11. Pär Thernström
    Member
    Plugin Author

    Posted 3 years ago #

    Wow, I solved it 7 months ago! ;) Anyway...can't remember what it was then and I don't know if it's a similar problem this time. But thanks for all bug reports, they are helping. Still a bit of a problem to fix this since I can reproduce this. Will try a bit more in all browsers I can find...

  12. tradiart
    Member
    Posted 3 years ago #

    Pär, I'm really sorry... :-(

    I have activated debug mode, no warnings at all.

    Also deactivated all plugins, only activated CMS Tree Page View and the same.

    Posts and articles don't work BUT my custom post type is not afected!! :-O They are working fine.

  13. Pär Thernström
    Member
    Plugin Author

    Posted 3 years ago #

    Any chance I can get access to you installation, so I can try it out and see for myself. If this is possible you can send more info to: par.thernstrom@gmail.com.

  14. tradiart
    Member
    Posted 3 years ago #

    Thank you, email sent. :-)

  15. Pär Thernström
    Member
    Plugin Author

    Posted 3 years ago #

    Thanks @tradiart! I actually think I found the cause of this: it's the keyboard shortcuts that can be enabled for a user (to moderate and browser comments).

    Can you who have problems try to disable keyboard shortcuts and tell me if it made any difference?

    Thanks a lot!

    (From the codex: "Keyboard shortcuts are enabled on a per-user setting, and can be turned on by visiting the Profile panel in Administration > Users > Your Profile.")

  16. tradiart
    Member
    Posted 3 years ago #

    Thank you Pär!

    I have deactivated keyboard shortcuts and now works perfect!! Posts, pages and custom post types can be edited from code directly.

    I have just make a little donation :)

  17. Mike Stop Continues
    Member
    Posted 3 years ago #

    Yes! Thanks!

  18. tradiart
    Member
    Posted 3 years ago #

    Issue solved in 0.7.17. :-)

    Thank you Pär.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic