WordPress.org

Ready to get started?Download WordPress

Forums

classyfrieds
[resolved] No link in Admin UI? (9 posts)

  1. michael walker
    Member
    Posted 1 year ago #

    Hi,
    I just installed your plug-in, but I'm not seeing a link underneath 'Posts' in the Admin UI - or anywhere else - so I'm unable to create any categories etc. I'm using WP 341 and the twenty-ten theme, if that helps.
    TIA.

    http://wordpress.org/extend/plugins/classyfrieds/

  2. wpprogrammeurs.nl
    Member
    Plugin Author

    Posted 1 year ago #

    Michael,

    classyfrieds works with custom posts (to keep things neat and separated).
    Anytime custom posts are used, these 'posts' do not end up in your 'posts' block in the Admin UI. Instead you should look for a 'classyfrieds' block.

    There you can write 'posts' called classyfrieds, and see listings that users submitted. There you can also create classycats (a custom type of categorie that only shows up in the classifieds system).

    in short, create classycats not categories. See screenshot : http://classyfrieds.com/shots/menu.png

  3. michael walker
    Member
    Posted 1 year ago #

    Thanks for the prompt reply. I'm maybe not making myself clear. http://classyfrieds.com/shots/menu.png - This link (below 'Posts', called Classyfrieds) is the one I'm not seeing.

  4. wpprogrammeurs.nl
    Member
    Plugin Author

    Posted 1 year ago #

    this one is buried deep but it's worth the shot. Do you have the screen-options checked for these custom posts ?
    (Don't ask me why but this must be WordPress's least intuitive feature).

    http://classyfrieds.com/shots/scropt.png
    go to appearance - > menus - then select screen options top right.

    If this does not solve your issue please send us a PM > info [at] wordpressprogrammeurs.nl

  5. michael walker
    Member
    Posted 1 year ago #

    I have found out what is causing this and am posting back here in case it's of use to others. I have the W4 Post List plug-in installed and it appears in the Admin menu immediately beneath 'Posts' - that is, in the position Classyfrieds is occupying in your example. If I de-activate this plug-in, then Classyfrieds shows up in my Admin UI. Trouble is, I do use this plug-in (W4 Posts), so de-activating it on a long-term basis is not an option for me. So - that's the cause. Do you think a solution might be possible?

  6. wpprogrammeurs.nl
    Member
    Plugin Author

    Posted 1 year ago #

    good catch, that was helpful ! Both plugins occupy the same menu position. Just happens that W4 won.

    if you are comfortable with the built in plugin editor:
    go to classyfrieds -> init.php and put 2 slashes in front of the menu postion line (line 29 ) as follows :

    // create the custom posts
    function create_classyfrieds_type() {
    		register_post_type('classyfrieds',
    		array(
    		'description' => 'classified listings for the classyfried system',
    		'public' => true,
            //'menu_position' => 6,   <<<<-----------<<<<---------
    		'show_ui' => true,
    		'show_in_menu' => true,
    		'show_in_admin_bar' => true,
    		'capability_type' => 'post',
    		'hierarchical' => false,

    This will move the whole classyfrieds block to the bottom of the menu tree. Although we don't like being last in the list we'll remove the line in the next update :-)

    [Moderator Note: Please post code or markup snippets between backticks or use the code button. As it stands, your code may now have been permanently damaged/corrupted by the forum's parser.]

  7. michael walker
    Member
    Posted 1 year ago #

    Thanks - that seems to have sorted it out.

  8. michael walker
    Member
    Posted 1 year ago #

    Hmmm....well, now I'm getting this: Warning: include(/web1/user270/website/Newsite/wp-content/plugins/classyfrieds/themefiles//language/english.php) [function.include]: failed to open stream: No such file or directory in /web1/user270/website/Newsite/wp-content/plugins/classyfrieds/themefiles/cats-listing.php on line 12.
    Two things strike me about this: First, notice the double '//' at 'themefiles//language'and second, there is no file called 'english.php' in that language folder. There's one called 'lang_english.php' though...

  9. digidownload.nl
    Member
    Plugin Contributor

    Posted 1 year ago #

    the whole language system was revamped in V 2.3 so using the latest version you should not get any warnings anymore.

    If needed use the flush button on the bottom-right in the classyfrieds admin section.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic