WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Classy wp_list_pages] Last class not working (10 posts)

  1. Last class doesn't seem to work for me. On line 119

    if ( $t == 'meti_egap' ) {

    the token is meti_egap"=ssalc

    http://wordpress.org/extend/plugins/classy-wp-list-pages/

  2. Alex Dunae
    Member
    Posted 4 years ago #

    Thanks for the report Dean. 1.3.2 will be available in a few minutes; give it a try and let me know if it works for you.

  3. Thanks Alex but still doesn't work :(

    There seems to be no ul in the tokens so $list_depth never decrements?

    If I start list depth at 1 $rev_class gets added before the class="...

    Can't think of an easy fix...

  4. Duno if this helps but this is how I hacked the old version to work

    if ( $t == 'meti_egap"=ssalc'  ) {
        $t = 'meti_egap '.  $rev_class . '"=ssalc';
        $list_depth += 1;
    }
  5. Alex Dunae
    Member
    Posted 4 years ago #

    Can you send me the HTML source of the list of pages? code at dunae dot ca

  6. livelearncreate
    Member
    Posted 4 years ago #

    I am having this same problem with the last item using this Plugin with WordPress 2.8.6

    Any updates or fixes?

    Thanks.

  7. christiemade
    Member
    Posted 4 years ago #

    Here is a sample output:

    <ul>
    <li class="first page_item page-item-2"><a href="http://02e95c6.netsolhost.com/blog/?page_id=2">About Us</a> <ul>
    <li class="first last page_item page-item-11"><a href="http://02e95c6.netsolhost.com/blog/?page_id=11">What we do</a> </li>
    </ul> </li>
    <li class="page_item page-item-17 current_page_item"><a href="http://02e95c6.netsolhost.com/blog/?page_id=17">Technology Consulting</a> </li>
    <li class="page_item page-item-21"><a href="http://02e95c6.netsolhost.com/blog/?page_id=21">Business Development</a> </li>
    <li class="page_item page-item-19"><a href="http://02e95c6.netsolhost.com/blog/?page_id=19">Product Placement</a> </li> 
    
    <li class="page_item page-item-27"><a href="http://02e95c6.netsolhost.com/blog/?cat=3">News</a> </li></ul>
  8. livelearncreate
    Member
    Posted 4 years ago #

    Bump.
    I had to reinstall a previous version of this plugin when I absentmindedly updated this plugin through the dashboard.

    Warning - after updating the "last item" feature doesn't work so exisiting live sites that use this with CSS styling will see the last items in their menus and such change.

    Any updates on this?

  9. plinth
    Member
    Posted 3 years ago #

    I had to install version 1.3 until the "last" class would apply. Works fine, but updating a plugin should make it work better, not break it!

  10. Spencer Hill
    Member
    Posted 3 years ago #

    I'm using WordPress 3.x and version 1.3.2 and I'm not getting the "last" class either.

Topic Closed

This topic has been closed to new replies.

About this Topic