WordPress.org

Ready to get started?Download WordPress

Forums

CKEditor For WordPress
Subscribers can't embed images in comments (7 posts)

  1. Who_Dat
    Member
    Posted 2 years ago #

    I figure this is a permissions issue, but I can't figure out what combination of settings it takes to make it go away. I, as admin, can embed a photo in a comment or reply; but my subscribers can't. Not in Firefox, not in Safari, not in Chrome. IE hasn't been mentioned, which warms my heart. Still, It's driving them nuts.

    One possible problem is that "File Browser" is currently disabled, and can't be enabled. Every time I try, when I click back to that screen it's disabled again. As I understand it, though, this enables you to choose a file from your desktop, whereas clicking the "Image" icon in the Comment box simply pops up a properties form that allows you to type in a URL. Seems like a separate function to me.

    http://wordpress.org/extend/plugins/ckeditor-for-wordpress/

  2. michal
    Member
    Plugin Author

    Posted 2 years ago #

    Hi @Who_Dat,
    your issue looks like related with CKFinder (File Browser) permissions settings. Please check readme.txt file in CKFinder subdirectory in CKEditor plugin directory.
    In this file there is a description how to install CKFinder File Browser.
    After correctly install of CKFinder, you can set users permissions in
    "CKFinder Options" options in Upload Options tab of CKEditor's plugin settings.

  3. seand11
    Member
    Posted 2 years ago #

    I'm having the same issue, but CKFinder shouldn't be the issue as we're trying to embed external images?

    Admin can but other users can't.

    Please advise. :)

  4. michal
    Member
    Plugin Author

    Posted 2 years ago #

    @seand11,
    please can you write steps to reproduce to your issue?
    What exactly you do and where is a problem.
    Does it works fine where you disable CKEditor for wordpress plugin ?

  5. seand11
    Member
    Posted 2 years ago #

    This fixed it, in functions.php! WordPress was stripping the tags, not the editor.

    // Allow img tags.
    global $allowedtags;
    $allowedtags['img'] = array(
                            'alt' => array (),
                            'align' => array (),
                            'border' => array (),
                            'class' => array (),
                            'height' => array (),
                            'hspace' => array (),
                            'longdesc' => array (),
                            'vspace' => array (),
                            'src' => array (),
                            'style' => array (),
                            'width' => array (),
    );
  6. michal
    Member
    Plugin Author

    Posted 2 years ago #

    @seand11 thank you for you investigation :)

  7. sarunas13
    Member
    Posted 1 year ago #

    @seand11

    Can you tell us how exactly you fixed it?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic