WordPress.org

Ready to get started?Download WordPress

Forums

CKEditor For WordPress
Stop CKEditor from being used in 'Edit Comment' feature. (11 posts)

  1. ranpha
    Member
    Posted 2 years ago #

    Is there any way to stop CKEditor from being used when I edit blog comments? I only want to use it for making/editing blog posts and pages.

    http://wordpress.org/extend/plugins/ckeditor-for-wordpress/

  2. michal
    Member
    Plugin Author

    Posted 2 years ago #

    @ranpha sorry for late reply.
    In this moment there is no such option.
    You can turn off CKEditor for use during adding comment by uncheck "Use CKEditor as comment editor" option in "CKEditor - Basic Settings" page.
    However this don't turn off CKEditor during comment edit.

  3. Eric Murphy
    Member
    Posted 2 years ago #

    Please add an option to turn CKEditor off as comment editor. It destroys my formatting.

  4. Try

    http://your-wordpress-url/wp-admin/admin.php?page=ckeditor_basic_options

    and uncheck Use CKEditor as comment editor option.

    It's under CKEditor -> Basic Settings.

    Edit:
    Oh, THAT comment editor. Looking.

  5. Eric Murphy
    Member
    Posted 2 years ago #

    @Dembowski "Oh, THAT comment editor. Looking. "

    Yeah, not the comment editor for adding comments but the comment editor for the mods/admins when editing comments.

    "Quick Edit" a comment works.
    "Edit" a comment goes to
    /wp-admin/comment.php?action=editcomment&c=xxxx

    and assumes HTML layout for a comment hence deletes all paragraphs and puts everything into one long line.

  6. Eric Murphy
    Member
    Posted 2 years ago #

    The new version (3.6.3) made it even worse, since now the click on "Reply" in the admin comment area brings up CKEditor.

    I have to disable CKEditor each time I want to reply to a comment.

    Sucks big time.

  7. ranpha
    Member
    Posted 2 years ago #

    OMG, that's correct. There should be an option to disable CKEditor for comment management (edit comments and reply comments) in WordPress dashboard, while keeping CKEditor strictly for post/page creation/editing.

  8. michal
    Member
    Plugin Author

    Posted 2 years ago #

    @ranpha and @others. We are working to improve this behaviour (disabling CKEditor as comment editor). This should works like @ranpha wrote.
    @knn adding reply with CKEditor in dashboard should works in latest release. Do you have any errors when you use CKEditor there?
    Please be patient.

  9. ranpha
    Member
    Posted 2 years ago #

    Using CKEditor for comment management would have been OK in my book if the formatting isn't destroyed. For example: if I have a comment with 2 paragraphs in it and I click the 'edit comment' link, the 2 paragraphs will be merged into one large paragraph instead.

  10. Eric Murphy
    Member
    Posted 2 years ago #

    @michal_cksource

    Yes, I have problems, both with adding new comments (reply) and with old comments (edit).

    When I add new comments then quotes are saved as curly quotes which messes around with some preg_replace code that I use for comments.

    When I edit old comments it merges all paragraphs into 1 long line.

    But the issue is a general issue about being able to turn the editor off completely for comment management.

    Even now although "Quick Edit" doesn't show CKEditor anymore (you corrected that behaviour, thank you) Quick Edit doesn't work correctly since the buttons like "(b)old" are missing.

  11. michal
    Member
    Plugin Author

    Posted 2 years ago #

    @knn,
    thank you for detailed informations. We will try fix these issues.
    Please be patient.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic