WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: CKEditor For WordPress] how to stop editor from inserting elements (5 posts)

  1. MathiasAeschlimann
    Member
    Posted 2 years ago #

    When I save a post/page, CKeditor adds <p> </p> and/or elements to the mark-up.

    How do I prevent that?

  2. michal
    Member
    Posted 2 years ago #

    @MathiasAeschlimann adding <p>&nbsp;</p> in some situations is issue related with CKEditor library. It is known issue. We should wait for CKEDitor developers to fix this issue.

  3. MathiasAeschlimann
    Member
    Posted 2 years ago #

    ok, thank you, are there any informations on in what circumstances this gets added or what mark up structures to use for avoiding this?

  4. MathiasAeschlimann
    Member
    Posted 2 years ago #

    Wrapping <img> in <figure> seems to prevent <p> </p> immediately after <img>.

  5. michal
    Member
    Posted 2 years ago #

    This option also can help: link to documentation. I forgot abut it.

Topic Closed

This topic has been closed to new replies.

About this Topic