WordPress.org

Ready to get started?Download WordPress

Forums

CKEditor For WordPress
Blank white edit screen (36 posts)

  1. FranklynJones
    Member
    Posted 2 years ago #

    Hi there,

    After installation of your plugin, I have a blank white screen when editing. I've followed the instructions for installation but I just can't seem to get it to work

    Thanks very much for your time,

    -FJ

    http://wordpress.org/extend/plugins/ckeditor-for-wordpress/

  2. michal
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,
    please try use latest DEV version from link. Please write us if it helps or not.

  3. FranklynJones
    Member
    Posted 2 years ago #

    Thanks for your quick reply - unfortunately I'm still getting the same issue.

    Cheers,
    -FJ

  4. michal
    Member
    Plugin Author

    Posted 2 years ago #

    Thank you for checking latest DEV.
    Please check in Firebug (Firefox add-on) console if you have any errors .
    Please also check in firebug's net tab if all request are correct.

  5. Alex Sherman
    Member
    Posted 2 years ago #

    I had the same issue, afer debugging with firebug and crossing it with Apache logs, I found out that the plaugin was requesting the JS files using the HTTPS protocol prefix. After a short investiagtion, I found that in file ckeditor_class.php in line 30 there was:

    if($_SERVER['HTTPS']) {
      $siteurl = str_replace('http:', 'https:', $siteurl);
      $this->plugin_path = str_replace('http:', 'https:', $this->plugin_path);
    }

    Apparentaly my server configuaration was producong

    $_SERVER['HTTPS']='off'

    The following fix should be applied to the plugin code, using a core wordpress function to check the required protocol:

    if(is_ssl()) {
      $siteurl = str_replace('http:', 'https:', $siteurl);
      $this->plugin_path = str_replace('http:', 'https:', $this->plugin_path);
    }
  6. michal
    Member
    Plugin Author

    Posted 2 years ago #

    @Alex Sherman thank you for your search and suggestion how to fix this issue. We try fix this as soon as possible. Please be patient.

  7. dczepierga
    Member
    Plugin Author

    Posted 2 years ago #

    @Alex Sherman thx for your help, i commit changes to SVN.

    Greetings

  8. Bannerweb GmbH
    Member
    Posted 2 years ago #

    In my opinion this plugin won't load on every webserver running IIS with PHP using ISAPI. The value of $_SERVER['HTTPS'] would be 'off' and in this case not empty as expected...

    When will be the next plugin update?

    Thanks for the great work!

  9. Alex Sherman
    Member
    Posted 2 years ago #

    Actually I had this on Apache on Ubuntu system (installed as Zend Server Ce PHP 5.3)

  10. michal
    Member
    Plugin Author

    Posted 2 years ago #

    @Bannerweb GmbH,
    this bug is fixed in latest DEV version. Please try use it.
    Dev version has also CKEditor 3.6.3 (latest one).

  11. dmillerzx
    Member
    Posted 2 years ago #

    I'm still having some issues with the a blank editor after enabling CKEditor...

    The only error I'm seeing when I attempt to make an edit, is as follows.

    Also I am on the latest DEV version.

    Headers:

    GET ckeditor.js?ver=3.3.2

    500 Internal Server Error

    www2.autani.local

    617 B

    172.21.18.66:80

    4ms
    ParamsHeadersResponseCache
    Response Headersview source
    Connection close
    Content-Length 617
    Content-Type text/html; charset=iso-8859-1
    Date Fri, 18 May 2012 18:48:14 GMT
    Server Apache/2.2.15 (CentOS)
    Request Headersview source
    Accept */*
    Accept-Encoding gzip, deflate
    Accept-Language en-us,en;q=0.5
    Connection keep-alive
    Cookie wordpress_aa2d82e81d80d2af647335df946511f3=admin%7C1338574660%7C31745ca464a06a0eb1f66968d7454827; wordpress_logged_in_aa2d82e81d80d2af647335df946511f3=admin%7C1338574660%7C332c60f492fe4830edec0ddd5f34d08a; wp-settings-time-1=1337366894; wordpress_test_cookie=WP+Cookie+check
    Host www2.autani.local
    Referer http://www2.autani.local/wp-admin/post.php?post=1&action=edit
    User-Agent Mozilla/5.0 (Windows NT 6.1; rv:12.0) Gecko/20100101 Firefox/12.0

    Response:

    <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html><head>
    <title>500 Internal Server Error</title>
    </head><body>
    <h1>Internal Server Error</h1>
    <p>The server encountered an internal error or
    misconfiguration and was unable to complete
    your request.</p>
    <p>Please contact the server administrator,
    root@localhost and inform them of the time the error occurred,
    and anything you might have done that may have
    caused the error.</p>
    <p>More information about this error may be available
    in the server error log.</p>
    <hr>
    <address>Apache/2.2.15 (CentOS) Server at www2.autani.local Port 80</address>
    </body></html>

  12. dmillerzx
    Member
    Posted 2 years ago #

    Issue solved! I had to disable the .htaccess file by renaming it .htaccess.bk everything is working now :) Any negatives to disabling that file??

  13. michal
    Member
    Plugin Author

    Posted 2 years ago #

    @dmillerzx,
    you mean .htaccess file in CKEditor plugin directory ?
    This kind of issues are related with server configuration.
    If everything works fine after your change, it should be ok.

  14. dmillerzx
    Member
    Posted 2 years ago #

    Yes I completely disabled the .htaccess file under plugins/ckeditor-for-wordpress/ckeditor After doing this CKEditor loads as it should, no more white/blank editor! :) :)

    I'm not sure where I would have configured the server wrong, started up a fresh VM for this guy. Fresh CentOS 6.2, with latest Apache, mySQL, and dependencies.

    Thanks for the feedback.

  15. smile-
    Member
    Posted 2 years ago #

    Hello.

    I had the same problem (blank white editor screen).

    Because the plugin was working up to some point I later discovered that the "Google XML Sitemaps v3 for qTranslate" (3.2.7.1) plugin was causing this plugin to stop working.

    Hopefully this will help someone...

  16. michal
    Member
    Plugin Author

    Posted 2 years ago #

    @smile-,
    can you write us if you have any errors in Firebug or similar tool when you try to use CKEditor for WordPress and "Google XML Sitemaps v3 for qTranslate" plugins

  17. smile-
    Member
    Posted 2 years ago #

    I tested it before and there was no errors. If you'd like, I can perform additional tests if needed.

    I tested stable version, development release and also SVN version from yesterday.

  18. duncanmc
    Member
    Posted 2 years ago #

    I am getting white edit screen. I am using WP 3.4 and CKeditor 3.6.3. Firefox 13 is giving this error:

    Timestamp: 2012/06/26 7:42:34 PM
    Error: evt.editor.config["toolbar_" + evt.editor.config.toolbar] is undefined
    Source File: http://www.mysite.com/blog/wp-content/plugins/ckeditor-for-wordpress/includes/ckeditor.utils.js?ver=3.4
    Line: 19

  19. dczepierga
    Member
    Plugin Author

    Posted 2 years ago #

    Ok we will try to check this asap.
    Could u also write which plugins do u use? Because it could be compatibility problem with other modules...

    Greetings

  20. duncanmc
    Member
    Posted 2 years ago #

    Fixed the problem. Error in .htaccess was the reason. Sorry.

  21. michal
    Member
    Plugin Author

    Posted 2 years ago #

    @duncanmc,
    thank you for checking this and give as a note about results.

  22. webvisuals
    Member
    Posted 1 year ago #

    I'm having the same problem and found a conflict with the EasyRotator plugin. Deactivate EasyRotator, Ckeditor works wonderfully, activate it and the dreaded White Screen takes over

  23. michal
    Member
    Plugin Author

    Posted 1 year ago #

    @webvisuals thank you for noticing this. We try to check this as soon as possible.

  24. DWUser.com
    Member
    Posted 1 year ago #

    Hi @webvisuals ,

    We're the developers of the EasyRotator plugin.

    There are some serious incompatibility issues with CKEditor because of the way WordPress is engineered around the TinyMCE editor. These issues affect our plugin as well as quite a few others.

    We recommend that you consider using Ultimate TinyMCE instead of CKEditor: http://wordpress.org/extend/plugins/ultimate-tinymce/ . It offers many options while maintaining compatibility with EasyRotator for WordPress and many other plugins as well.

    Sincerely,
    Drew O'Neill

  25. michal
    Member
    Plugin Author

    Posted 1 year ago #

    @DWUser.com,
    our plugin is created to replace TinyMce with CKEditor editor in wordpress. We create this plugin for CKSource company which develops CKEditor. For mentioned reasons we can't stop using CKEditor , because our goal is to enter CKEditor into WordPress and give people opportunity to use CKEditor Wysiwyg editor.
    We try check and fix conflicts between our plugin and EasyRotator plugin.

  26. webvisuals
    Member
    Posted 1 year ago #

    Michal, did you get a chance to fix the plugin to be compatible with the Easy Rotator plugin? I've tried Ultimate and I ran into the same problems with it changing my code around and weird things happening. I'd prefer to use your product.

  27. michal
    Member
    Plugin Author

    Posted 1 year ago #

    @webvisuals,
    nothing was changed about this.

  28. JonLandon
    Member
    Posted 1 year ago #

    I have a white blank area when I use with Twentyeleven Theme. What is happening is the text is white on a white background, therefore it looks like nothing is there. I can highlight it with the cursor and it appears. Also all of my icons above the edit area disappear. It seemed to happen upon install of either Google XML sitemap or SEO Yoast. It was working until then. I am not using easy rotator plugin.

    I'm just deleting CKEditor because it caused me to waste a whole day messing around with it. But please email me when it is fixed

  29. JonLandon
    Member
    Posted 1 year ago #

    Answer: Google XML Sitemap conflicts with CKEditor...I can use one or the other, but not both....so I disable CKEditor until I need to edit pages. Then I disable Googlr XML Sitemap and enable CKEditor when I need to make changes and then switch back.

    Kinda dumb but it works..

  30. michal
    Member
    Plugin Author

    Posted 1 year ago #

    @JonLandon,
    yes we know that some users have problem with conflict between our plugin and Google XML Sitemap. We try check this . Please be patient.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic