WordPress.org

Ready to get started?Download WordPress

Forums

CKEditor For WordPress
[resolved] after update wordpress to 3.3 (16 posts)

  1. SITEWEB44
    Member
    Posted 2 years ago #

    Nothing apear, i lost the editor CKE after i update wordpress to 3.3, i've got only the wordpress's default editor

    PHILIPPE

    http://wordpress.org/extend/plugins/ckeditor-for-wordpress/

  2. michal
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,
    yes we know this and we are working to fix this.
    Please check latest dev version and give us a note if this works for you.

  3. Col Pain
    Member
    Posted 2 years ago #

    Same here. After the update to WordPress 3.3, the CKEditor is lost. Tried the dev version and it works for me.

  4. michal
    Member
    Plugin Author

    Posted 2 years ago #

    Thank you @Col Pain for testing DEV version. We will create new release as soon as possible.

  5. michal
    Member
    Plugin Author

    Posted 2 years ago #

    New release was created today. Please use it.

  6. SITEWEB44
    Member
    Posted 2 years ago #

    it's works for me

    Thank you

  7. neelloc21
    Member
    Posted 2 years ago #

    The dev version didn't work for me, but clearing the browser cache did.

  8. Benjamin Storrie
    Member
    Posted 2 years ago #

    With the final version of WP 3.3, I get an error at the dashboard about a call to a non-existent function because it's deprecated. (call to non-existent function _WP_Editors::get_editor()) As soon as I disable CKEditor (manually) I can access the dashboard again.

  9. michal
    Member
    Plugin Author

    Posted 2 years ago #

    @Benjamin Storrie in which file there is a call to this non existed file (the error should show this). Do you use latest version of ckeditor-for-wordpress plugin (3.6.2.4) ?

  10. Benjamin Storrie
    Member
    Posted 2 years ago #

    @michael_cksource, it's the following error:

    Fatal error: Call to undefined method _WP_Editors::editor_settings() in /home/site/site.com/wp-admin/includes/deprecated.php on line 728

  11. Benjamin Storrie
    Member
    Posted 2 years ago #

    This only occurs when I install ckeditor. All other plugins seem to function just fine. Also, I uploaded it as a zip, and after install, got the same error, but now the folder isn't in wp-content/plugins, so I can't delete or rename the plugin folder. Any ideas?

    Thanks!

  12. michal
    Member
    Plugin Author

    Posted 2 years ago #

    Hi @Benjamin Storrie there is similar topic about error reported by you: http://wordpress.org/support/topic/plugin-ckeditor-for-wordpress-fatal-error-after-upgrading-to-wordpress-33?replies=4. To this moment I can't reproduce this. We try to check this again. Please be patient.

  13. wmike1503
    Member
    Posted 2 years ago #

    ckEditor seems to be broken with WordPress 3.3 - installing 3.6.2.4 kills my site - the only way to get it back is to remove ckEditor completely.

  14. michal
    Member
    Plugin Author

    Posted 2 years ago #

    @wmike1503 please try use latest DEV version:
    link to dev version.
    In DEV version error mentioned by @Benjamin Storrie is fixed. Please check it.

  15. wmike1503
    Member
    Posted 2 years ago #

    Thanks for that. Seems to load and activate OK now.

    Still have a recurring issue with the filemanager side of things.

    Although the uploads directory is set to wp-content/uploads/ - the filemanager is unable to list any files that reside in the folder. Browsing the server gets you here -

    'wp-content/plugins/ckeditor-for-wordpress/filemanager/browser/default/browser.html?Connector=../../connectors/php/connector.php&type=Images&CKEditor=content&CKEditorFuncNum=2&langCode=en'

    Obviously not getting to the wp-content/uploads folder. As a contrast - using Foliopress - browsing for an file takes you to the correct directory.

    This has been the same with all versions I have used.

    Cheers,

    Mike

  16. michal
    Member
    Plugin Author

    Posted 2 years ago #

    @wmike1503 we have just released new version of plugin.
    We try check and fix browsing problem in future versions of plugin. Please be patient.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic