WordPress.org

Ready to get started?Download WordPress

Forums

cbnet Really Simple CAPTCHA Comments
[resolved] One slight issue with the browser back button (4 posts)

  1. jberg1
    Member
    Posted 3 years ago #

    Hello, I'm using the Captcha plugin for my comments. It looks to be working fine (Thank you). I'm calling it in the comments.php file using
    <?php cbnet_comment_captcha(); ?>

    One issue I'm having, is when the user enters the captcha wrong and the system gives the error telling the user to click the back button and try again. When the user clicks back the captcha doesn't change, then when the user puts it in correctly it still gives the same error.

    The only way around this is to fully reload the page and enter it correctly the first time. Seems like a cache issue. Any idea how to get around this? It doesn't do the same thing using the captcha on the contact form, but that adds errors under the input instead of requiring to click the back button.

    Thanks for any help.

    http://wordpress.org/extend/plugins/cbnet-really-simple-captcha-comments/

  2. Chip Bennett
    Theme Review Admin
    Plugin Author

    Posted 3 years ago #

    Hmm... I will have to take a look at the Comment Form 7 CAPTCHA code again, and see what it's doing differently.

  3. jordibalcells
    Member
    Posted 3 years ago #

    I solved this editing the main plugin file cbnet-really-simple-captcha-comments.php. Comment out the line 112:

    //$cbnet_comment_captcha->remove($cbnet_comment_captcha_prefix);

    Bye

  4. dodong_cocoy
    Member
    Posted 2 years ago #

    @jordibalcells

    really simple //
    works for me

    thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic